Foros del Web » Creando para Internet » Flash y Actionscript »

problema con gotoandplay...

Estas en el tema de problema con gotoandplay... en el foro de Flash y Actionscript en Foros del Web. wenas gente, tengo un "grave" problema, seguro que es una tonteria pero bueno, os explico, tengo una maquina (una imagen de una retroexcavadora), que del ...
  #1 (permalink)  
Antiguo 15/07/2008, 11:41
 
Fecha de Ingreso: noviembre-2007
Mensajes: 40
Antigüedad: 10 años, 1 mes
Puntos: 0
problema con gotoandplay...

wenas gente, tengo un "grave" problema, seguro que es una tonteria pero bueno, os explico, tengo una maquina (una imagen de una retroexcavadora), que del fotograma 1 al fotograma 15 lo que hace (con una interpolacion de movimiento) es aparecer en la pantalla y quedarse en el sitio donde yo quiero, en el fotograma 16 y en otra capa diferente pongo el script siguiente:

gotoandplay(15);

con esto lo que quiero hacer esque la pelicula llegue al fotograma 16 de este pase al 15 que llega al 16 y otra vez al 15 asi indefinidamente, y esque, en el 16 le muevo la coordena y (a la imagen) de 0 a -1, para que me entendais, lo que quiero es dar la apariencia de que el motor de la maquina esta encendido, haciendo el efecto de que parezca que la maquina vibra...

pero bien cuando pruebo la pelicula no vibra, encima e puesto un 15 en el fotograma 15 y un 16 en el fotograma 16 para comprobar una cosa, y el 16 no aparece por ningun lado, osea, es como si el fotograma 16 nunca llegara a visualizarse o ejecutarse, a ver si podeis echarme una manilla, gracias
  #2 (permalink)  
Antiguo 15/07/2008, 13:53
Avatar de PabloSutra  
Fecha de Ingreso: octubre-2006
Ubicación: Guadalajara, México
Mensajes: 222
Antigüedad: 11 años, 2 meses
Puntos: 0
Respuesta: problema con gotoandplay...

Que tal templas, lo que podrias hacer porqu a veces el Flash se medio desentiende con el gotoandplay, trata de poner en vez de gotoAndPlay(15), si estas en el 16 usa el prevFrame(), esta función, hace que se vaya al frame anterior en este caso 15 como no tiene señal de stop(); sigue corriendo la animacion.

Espero te sirva
SALUD!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:55.