Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con las escenas

Estas en el tema de Problema con las escenas en el foro de Flash y Actionscript en Foros del Web. Hola amigos. Os expliko mi problema a ver si alguno es tan amable de ayudarme. Estoy haciendo un site en flash, y he metido las ...
  #1 (permalink)  
Antiguo 02/10/2005, 06:31
Avatar de ivanhoe_gg  
Fecha de Ingreso: octubre-2004
Ubicación: Madrid
Mensajes: 52
Antigüedad: 13 años, 2 meses
Puntos: 0
Problema con las escenas

Hola amigos. Os expliko mi problema a ver si alguno es tan amable de ayudarme.

Estoy haciendo un site en flash, y he metido las distintas secciones de la pagina cada una en una escena, ya que cada vez tendran mas contenido y he de ir añadiendo fotogramas.

A la izquierda tengo un menu con botones, que al pinchar te llevan a la escena donde esta dicha seccion. El codigo que tengo puesto es:

Cita:
on (release) {
gotoAndPlay("videos","1");
}
Para que me lleve a la escena de videos, y reproduzca el fotograma 1. Y asi con las demas secciones, el problema es que al pinchar en un boton del menu, no me lleva a la escena indicada, sino a la escena siguiente de la actual.

No se si me he explicado bien.

Uso la version flash MX 2004, por si les sirve de ayuda.

En resumen, lo que necesito es saber si yo tengo hecho algo mal, o es un problema de la version del flash, y en cualquier caso que debo de hacer para conseguir que al pinchar en el boton vaya a la escena indicada y no a la siguiente.

Por cierto, tambien tengo una primera escena con un preloader por si sirve de algo.

Saludos y gracias x su atencion, y x leer todo este toston.
  #2 (permalink)  
Antiguo 02/10/2005, 08:58
Avatar de ivanhoe_gg  
Fecha de Ingreso: octubre-2004
Ubicación: Madrid
Mensajes: 52
Antigüedad: 13 años, 2 meses
Puntos: 0
ya lo solucione, debia ser un error del programa. Aki os pongo komo lo arregle x si os sirve de algo:

en cada escena le puse una etiketa al primer fotograma con el nombre de la escena, y en los botones vinculaba al fotograma en concreto, es decir, en la escena de videos llamo al primer fotograma videos, y en el boton que quiero que vincule a esa escena, pongo este codigo:

on (release) {
gotoAndPlay("videos");
}
y funciona perfectamente :D
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:56.