Foros del Web » Creando para Internet » Flash y Actionscript »

problema con links en una pagina web

Estas en el tema de problema con links en una pagina web en el foro de Flash y Actionscript en Foros del Web. Hola. soy nuevo en el foro y por eso no se si la pregunta que voy a hacer ya la habían resuelto....estuve navegando un poco ...
  #1 (permalink)  
Antiguo 01/08/2007, 12:07
 
Fecha de Ingreso: agosto-2007
Mensajes: 5
Antigüedad: 10 años, 4 meses
Puntos: 0
problema con links en una pagina web

Hola.
soy nuevo en el foro y por eso no se si la pregunta que voy a hacer ya la habían resuelto....estuve navegando un poco y no la encontré.

El problema es el siguiente, acabo de montar una pagina web desarrollada totalmente en flash, pero para el subirla organice los .swf en varios archivo html con la ayuda de dreamweaver. organize las carpetas de modo que tengo el index,html afuera y dos carpetas, una que se llama swfs y otra que se llama paginas (contiene los demas html). el problema es al momento de hacer los links. en este momento los tengo la siguiente accion en el boton

on (release) {
getURL("productos.html");
}

esta me funciona perfectamente en explorer, pero no en firefox, por lo cual la cambie por

on (release) {
getURL("paginas/productos.html");
}

que me funciona perfectyamente en firefox, pero no en explorer.......

?????? la verdad no entiendo estas "flashadas", alguien me puede expplicar.....tienen alguna otra forma para que me funcione en los dos navegadores.....

ah, se me olvidaba estoy utilizando flash cs3 pero el archivo lo cree como FlashFile (ActionScript 2.0).

Gracias
  #2 (permalink)  
Antiguo 01/08/2007, 13:51
 
Fecha de Ingreso: julio-2006
Mensajes: 18
Antigüedad: 11 años, 4 meses
Puntos: 0
Re: problema con links en una pagina web

Hola, eso ocurre porque estás llamando desde un archivo (html) que está dentro de un directorio a otro archivo (swf) que está en otro directorio distinto. Sinceramente no sé cómo hacer eso ya que a mí me han pasado cosas parecidas, y sobre todo con swf´s. Pero lo que puedes hacer es meter la carpeta SWFS dentro de la carpeta PAGINAS (aunque te tocaría cambiar los vínculos), y en teoría no deberías tener problemas.
Espero haberte sido de ayuda, un saludo
  #3 (permalink)  
Antiguo 01/08/2007, 14:04
 
Fecha de Ingreso: agosto-2007
Mensajes: 5
Antigüedad: 10 años, 4 meses
Puntos: 0
Re: problema con links en una pagina web

Gracias Reihzard, hare lo que me dices y despues te comento si me resulto
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:03.