Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con loadmovie

Estas en el tema de Problema con loadmovie en el foro de Flash y Actionscript en Foros del Web. buenos dias resulta que cargo un .swf con loadmovie en un movieclip que hago.. este swf es una web digamos.. que adentro tiene tambien movieclip ...
  #1 (permalink)  
Antiguo 19/12/2007, 22:18
Avatar de matuteworld  
Fecha de Ingreso: octubre-2007
Ubicación: San Miguel de Tucuman, Tucuman
Mensajes: 79
Antigüedad: 10 años, 2 meses
Puntos: 2
Pregunta Problema con loadmovie

buenos dias resulta que cargo un .swf con loadmovie en un movieclip que hago.. este swf es una web digamos.. que adentro tiene tambien movieclip con la informacion.. pero resulta que carga barbaro el loadmovie pero el menu que tiene este swf cargado por el loadmovie no anda.. que estara pasando? si no se entiende.. lo intentare explicar mas claro.. muchas gracias.
  #2 (permalink)  
Antiguo 20/12/2007, 01:39
Avatar de sirguy  
Fecha de Ingreso: septiembre-2006
Ubicación: Mallorca
Mensajes: 959
Antigüedad: 11 años, 2 meses
Puntos: 12
Re: Problema con loadmovie

Supongo que será un tema de rutas, supón que el menú que cargas tiene este código:

_root.menu.play();

Cuando cargas con loadMovie o loadMovieNum cambias por fuerza la ruta que hace funcionar el menu, un ejemplo:


loadMovieNum("menu.swf",1);

Entonces el menú será: _level1._root.menu.play(); (creo que iba así)


loadMovie("menu.swf",_root.clip);

Entonces el menú será: _root.clip.menu.play();


Al principio es un poco lioso.
__________________
Chanante!
  #3 (permalink)  
Antiguo 20/12/2007, 09:26
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Problema con loadmovie

Hola matuteworld:
El problema es de rutas.
Si estás usando el código: _root en la película que estás cargando y si usas loadMovieNum() no vas a tener problemas, pero si estás usando un MC_vacío como contenedor no va a funcionar, tendrías que colocar en el primer frame de la película que cargas éste código: this._lockroot = true;

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:25.