Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con loadmovie

Estas en el tema de Problema con loadmovie en el foro de Flash y Actionscript en Foros del Web. Hola, espero que podáis echarme uan mano. Tengo una película en la que los fondos se intercambian al hacer click en distintos botones. El fondo ...
  #1 (permalink)  
Antiguo 15/12/2008, 07:00
 
Fecha de Ingreso: mayo-2008
Mensajes: 163
Antigüedad: 9 años, 6 meses
Puntos: 1
Problema con loadmovie

Hola, espero que podáis echarme uan mano. Tengo una película en la que los fondos se intercambian al hacer click en distintos botones. El fondo se cambia mediante una transicion con una máscara. Todo va bien excepto porque durante unos frames se ve todo blanco. Imagino que es el loadmovie que tarda en cargar.
¿Cómo puedo hacer para que la secuencia comience hasta que el nuevo fondo esté cargado y así no ver frames en blanco?

Muchas grácias.
  #2 (permalink)  
Antiguo 15/12/2008, 07:41
Avatar de kukynet  
Fecha de Ingreso: noviembre-2008
Mensajes: 105
Antigüedad: 9 años
Puntos: 2
Respuesta: Problema con loadmovie

Amigazo en estos caso me parese que es conveniente usar MovieClipLoader.loadClip(), y controlar la carga .Fijate en la ayuda de flash, desde la 8 ya viene incorporado la explicacion.
Saludos
  #3 (permalink)  
Antiguo 16/12/2008, 03:17
 
Fecha de Ingreso: mayo-2008
Mensajes: 163
Antigüedad: 9 años, 6 meses
Puntos: 1
Respuesta: Problema con loadmovie

Gracias, tío. Me pongo ahora mismo en ello, a ver si lo logro.
  #4 (permalink)  
Antiguo 16/12/2008, 19:52
Avatar de wihe  
Fecha de Ingreso: noviembre-2006
Ubicación: Lima - Perú
Mensajes: 81
Antigüedad: 11 años
Puntos: 0
Respuesta: Problema con loadmovie

Cita:
Iniciado por Jamlet Ver Mensaje
Hola, espero que podáis echarme uan mano. Tengo una película en la que los fondos se intercambian al hacer click en distintos botones. El fondo se cambia mediante una transicion con una máscara. Todo va bien excepto porque durante unos frames se ve todo blanco. Imagino que es el loadmovie que tarda en cargar.
¿Cómo puedo hacer para que la secuencia comience hasta que el nuevo fondo esté cargado y así no ver frames en blanco?

Muchas grácias.
Si lo que necesitas es precargar las imágenes con moviecliploader, aquí te dejo un ejm: http://flash-creations.com/notes/dynamic_loadjpg.php

saludos
__________________
-----------------------
Willy Henostroza

Tecnología y Web 2.0
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:01.