Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con loadVariables

Estas en el tema de Problema con loadVariables en el foro de Flash y Actionscript en Foros del Web. Hola, Actualmente poseo un problema con loadVars en mi pelicula, se trata de que no jala las variables que imprime el archivo php. Intente con ...
  #1 (permalink)  
Antiguo 28/02/2005, 23:23
 
Fecha de Ingreso: febrero-2005
Mensajes: 97
Antigüedad: 12 años, 10 meses
Puntos: 0
Problema con loadVariables

Hola,
Actualmente poseo un problema con loadVars en mi pelicula, se trata de que no jala las variables que imprime el archivo php. Intente con uno txt con variables comunes y tampoco funciona, por lo que creo que algo mal estoy haciendo entonces explico lo que hace mi swf.

Un Texto dinámico se le asigna una variable(son 28 y pueden ser vistas en: http://www.mercosur.com.ve/variables_flash.php ) y el texto lo muevo a través de un simple motion tween. Listo =)

En el primer frame tengo lo siguiente:
loadVariables("variables_flash.txt", "_root", "GET");, seguidamente en el mismo frame añado todas las variables a un array y queda como:
band = new Array(banner1, banner2...);//puntos suspensivos porq son 28

Luego en el frame 2 digo que I=1; y en el 3 digo que ban=band[0 + i]; donde ban es la variable que el representa al texto dinámico.

Espero sus respuestas y gracias!
__________________

www.bre4k.com
motion graphics

  #2 (permalink)  
Antiguo 01/03/2005, 10:52
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
El problema es que con loadVariables no sabes cuando se han cargado las variables he inmediatamente las asignas a tu array siendo que aun no estan cargadas...

Lo mejor es usar LoadVars

algo asi

Código:
a = new LoadVars();
a.load("http://www.mercosur.com.ve/variables_flash.php");
a.onLoad = function() {
	trace(this.banner1);
	trace(this.banner2);
};
  #3 (permalink)  
Antiguo 01/03/2005, 12:41
 
Fecha de Ingreso: febrero-2005
Mensajes: 97
Antigüedad: 12 años, 10 meses
Puntos: 0
Gracias! intentaré a ver que sucede
__________________

www.bre4k.com
motion graphics

  #4 (permalink)  
Antiguo 01/03/2005, 13:32
 
Fecha de Ingreso: febrero-2005
Mensajes: 97
Antigüedad: 12 años, 10 meses
Puntos: 0
Me funcionó perfecto Tmeister, ahora solo me queda un detalle: los acentos.

Cuando flash carga todo los acentos los lee y los muestra como si fueran ◘
Cargue la fuente que uso a la librería y añadí a mi código:

system.useCodepage = true;

Alguna idea?
__________________

www.bre4k.com
motion graphics

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:36.