Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con mi menu "desplegable"

Estas en el tema de Problema con mi menu "desplegable" en el foro de Flash y Actionscript en Foros del Web. bueno... hola xD! este es mi primer msj a ver q sale xD! la cuestion es q tengo un menu que al hacer click se ...
  #1 (permalink)  
Antiguo 20/08/2007, 18:47
 
Fecha de Ingreso: abril-2007
Ubicación: Tandil, Bs As, Argentina
Mensajes: 106
Antigüedad: 10 años, 8 meses
Puntos: 2
Problema con mi menu "desplegable"

bueno... hola xD! este es mi primer msj a ver q sale xD!

la cuestion es q tengo un menu que al hacer click se corre hacia la izquierda (se va de la pantalla xD!)

mi codigo es asi:

on (release) {
if (Menu._currentframe>29) {
Menu.gotoAndPlay(16);
} else {
Menu.gotoAndPlay(31);
}
}

donde Menu es el nombre del movie clip (no de instancia) a donde debe dirigirse en caso de hacer click en el boton...

tambien habia intentado hacerlo cuando pasabas el mouse por encima del menu simplemetne al poner el mouse encima aparecia al quitarlo se iba... pero no funciono... T_T por si pueden hacer algo con eso, les paso el codigo que habia usado...

onEnterFrame = function () {
if (menumov.hitTest(_xmouse, _ymouse, false)) {
gotoAndPlay(2);
}
};

donde menumov es el nombre de instancia del movie clip

bueno... gracias por colaborar a mi causa =P

un saludo!
  #2 (permalink)  
Antiguo 21/08/2007, 07:11
Avatar de Mahalo  
Fecha de Ingreso: julio-2004
Ubicación: Mallorca (Illes Balears)
Mensajes: 1.121
Antigüedad: 13 años, 4 meses
Puntos: 12
Re: Problema con mi menu "desplegable"

Pues me temo que Menu sí debe ser el nombre de instancia para que funcione el código. El caso contrario estará buscando un elemento que no existe.

Saludos!
  #3 (permalink)  
Antiguo 21/08/2007, 12:22
 
Fecha de Ingreso: abril-2007
Ubicación: Tandil, Bs As, Argentina
Mensajes: 106
Antigüedad: 10 años, 8 meses
Puntos: 2
Re: Problema con mi menu "desplegable"

sencillamente sigue sin funcionar... no se porque es que deberia ser algo sencillo haces click en un boton y va a otro frame... no se porque no quiere T_T

seguire intentando si encuentro una respuesta les digo... gracias Mahalo por responder =D!
  #4 (permalink)  
Antiguo 21/08/2007, 13:19
 
Fecha de Ingreso: enero-2007
Mensajes: 68
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Problema con mi menu "desplegable"

oye me parece que te estas complicando con los codigos, en primero lugar, hacia donde lo quieres llevar a fuera de la pantalla, pues carga una instancia dobley listo
  #5 (permalink)  
Antiguo 21/08/2007, 14:20
 
Fecha de Ingreso: abril-2007
Ubicación: Tandil, Bs As, Argentina
Mensajes: 106
Antigüedad: 10 años, 8 meses
Puntos: 2
Re: Problema con mi menu "desplegable"

lo arregle elminando uno de los movie clips que vi que era innecesario, y haciendo que el gotoAndPlay sea en esa misma escena y no requiera de referancia de instancia... quedo muy lindo =D cuaqndo este colgado en la web les paso el link para que lo vean =D

saludos y gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:14.