Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con precarga y sonido

Estas en el tema de Problema con precarga y sonido en el foro de Flash y Actionscript en Foros del Web. Hola amigos del Foro: Se me ha planteado una cosa bastante incomprensible (al menos para mi), y no he encontrado ningún mensaje que hablara sobre ...
  #1 (permalink)  
Antiguo 27/06/2005, 12:42
 
Fecha de Ingreso: marzo-2003
Ubicación: Chivilcoy
Mensajes: 138
Antigüedad: 14 años, 8 meses
Puntos: 0
Problema con precarga y sonido

Hola amigos del Foro:

Se me ha planteado una cosa bastante incomprensible (al menos para mi), y no he encontrado ningún mensaje que hablara sobre el tema.
El problema es que tengo un swf con 2 escenas, una sirve de precarga, donde el primer frame tengo el siguiente codigo:
ifFrameLoaded ("Pelicula", 1) {
gotoAndPlay("Pelicula", 1);
}

En la otra escena ("Pelicula"), tengo el siguiente código en el primer frame:
s= new Sound();
s.attachSound("Sonido");
s.onSoundComplete = function() { s.start(); };
s.start();

El tema es que cuando se carga la segunda escena, el sonido comienza a "saltar", como si fuera un disco rayado, y no se reproduce normalmente.
He probado que si saco la escena de precarga, el sonido se reproduce correctamente.
Cómo puedo hacer para reproducir el sonido normalmente manteniendo la escena de precarga?
Desde ya muchas gracias por su ayuda
__________________
Leandro Mandarano
Cyper Developments
http://www.cyper.com.ar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:22.