Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con preload y loadmovie

Estas en el tema de Problema con preload y loadmovie en el foro de Flash y Actionscript en Foros del Web. Hola amigos. Estuve leyendo por el foro que cuando se carga un swf con loadmovie, y este tiene un preload, no sale el preload. Y ...
  #1 (permalink)  
Antiguo 12/10/2005, 12:02
Avatar de ivanhoe_gg  
Fecha de Ingreso: octubre-2004
Ubicación: Madrid
Mensajes: 52
Antigüedad: 13 años, 2 meses
Puntos: 0
Problema con preload y loadmovie

Hola amigos. Estuve leyendo por el foro que cuando se carga un swf con loadmovie, y este tiene un preload, no sale el preload. Y habia que cambiar _root por this.

Pues bien, a mi me ocurre este problema, pero al cambiar _root por this, no me funciona el preload, me pone en el porcentaje: "NAN%", y la barra no avanza conforme al numero de bytes cargados.

Aki os dejo el codigo del preload, que es el k tngo en la pelicula principal y me va perfecto:

Cita:
function cargando() {
var total, cargados, porcentaje;
total = _root.getBytesTotal();
cargados = _root.getBytesLoaded();
porcentaje = Math.floor((cargados*100)/total);
porcentaje_txt.text = porcentaje+" %";
barra_mc.gotoAndStop(porcentaje);
if (cargados == total) {
clearInterval(hiloPrecarga);
play();
}
}
var hiloPrecarga = setInterval(cargando, 1);
stop();
** barra_mc, es el clip de la barra de progreso ( dura 100 fotogramas ) **
** porcentaje_txt es el texto dinamico donde me envia el % cargado **

Espero que puedan ayudarme. Saludos.
__________________
<< Maestro de poco, alumno de mucho >>
  #2 (permalink)  
Antiguo 12/10/2005, 12:51
Avatar de ivanhoe_gg  
Fecha de Ingreso: octubre-2004
Ubicación: Madrid
Mensajes: 52
Antigüedad: 13 años, 2 meses
Puntos: 0
alguien me exa un kable???
__________________
<< Maestro de poco, alumno de mucho >>
  #3 (permalink)  
Antiguo 12/10/2005, 13:15
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola ivanhoe_gg:
Tienes que ponerle como nombre de instancia al campo de texto dinámico: porcentaje_txt.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 12/10/2005, 13:55
Avatar de ivanhoe_gg  
Fecha de Ingreso: octubre-2004
Ubicación: Madrid
Mensajes: 52
Antigüedad: 13 años, 2 meses
Puntos: 0
si lo tngo puesto :S
__________________
<< Maestro de poco, alumno de mucho >>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:36.