Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con preloader y attachmovie AS2.0

Estas en el tema de Problema con preloader y attachmovie AS2.0 en el foro de Flash y Actionscript en Foros del Web. Hola Tengo este problema: Mi preloader está en la escena 1. Cuando este termine de hacer lo suyo va a la escena 2 donde está ...
  #1 (permalink)  
Antiguo 28/01/2010, 08:17
 
Fecha de Ingreso: julio-2009
Mensajes: 27
Antigüedad: 11 años, 4 meses
Puntos: 2
Problema con preloader y attachmovie AS2.0

Hola

Tengo este problema:

Mi preloader está en la escena 1.
Cuando este termine de hacer lo suyo va a la escena 2 donde está la película con una sección del sitio.

Esta sección tiene sub-secciones que son galerías de fotos, para lo cual, mediante una función se trae la galería usando attachMovie.

El tema es que el MC que attachea las fotos tiene tildado "Exportar en el primer frame"... con lo cual se me hace mucho peso en el primer cuadro y el preloader no se alcanza a ver.

Si destildo la opción de "Exportar en el primer frame" no anda. No attachea las fotos.

Que se hace en estos casos?
  #2 (permalink)  
Antiguo 28/01/2010, 08:38
 
Fecha de Ingreso: julio-2009
Mensajes: 27
Antigüedad: 11 años, 4 meses
Puntos: 2
Respuesta: Problema con preloader y attachmovie AS2.0

Me auto-respondo con algo que encontré en otros foros:

De todas formas, me parece que es un parche, no es muy prolijo.

Lo que hago es destildarle la opción "exportar al primer frame" y luego tirar el MC que será atachado en un cuadro posterior al preloader, fuera del escenario, para que no se vea.

De esta manera, al compilarlo, el MC y todo su peso se cargarán en el cuadro que yo decida.

Lo dejo, por si alguien tiene el mismo problema.

Etiquetas: attachmovie, preloader
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:54.