Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Radio Button

Estas en el tema de Problema con Radio Button en el foro de Flash y Actionscript en Foros del Web. Les cuento, tengo un formulario que trabaja con php y funciona perfecto (gracias el_leon) salvo por un detalle... El mismo cuenta con dos radio buttons ...
  #1 (permalink)  
Antiguo 23/12/2003, 11:08
Avatar de conic  
Fecha de Ingreso: marzo-2003
Ubicación: Buenos Aires
Mensajes: 108
Antigüedad: 14 años, 8 meses
Puntos: 6
Problema con Radio Button

Les cuento, tengo un formulario que trabaja con php y funciona perfecto (gracias el_leon) salvo por un detalle...
El mismo cuenta con dos radio buttons para algo así...

IVA Responsable Inscripto: (Radio Button)
IVA Responsable No Inscripto: (Radio Button)

La idea como ya verán es que de acuerdo a lo que corresponda seleccionen. Los dos radio buttons tienen el mismo nombre de Grupo (Radio1) uno en false y el otro en true...

Esta película trabaja a la vez con un archivo en php para que todos los datos lleguen a un mail. El tema es que llega todo bien menos lo del radio button que desde el archivo php lo pido de esta manera:

Iva Resp Inscripto: $Radio1\n

En fin, si me pueden ayudar se los agradeceré mucho.

Saludos
__________________
:-D ] CoNic [
  #2 (permalink)  
Antiguo 23/12/2003, 12:28
Avatar de el_leon  
Fecha de Ingreso: diciembre-2003
Ubicación: Buenos Aires, Argentina
Mensajes: 182
Antigüedad: 14 años
Puntos: 0
hola conic,

para empezar, no tengo ninguna experiencia con el componente FRadioButton, pero como has despertado mi curiosidad, aquí me tienes.

Al parecer, no es lo mismo el nombre del grupo de opciones que el nombre de la variable que le pasas al php. De hecho, creo que si no creas una variable que levante el estado de los radiobuttons, no habrás pasado nada al php.

Lo que estuve haciendo (y funciona) es lo siguiente:
dentro del formulario seleccionas los radiobuttons y creas un movieclip con ellos. Le pones al nuevo mc las acciones:
Código:
onClipEvent (enterFrame) {
	if (this.Insc.getState()==true) {
		Radio1="Responsable Inscripto"
	}
	if (this.NoInsc.getState()==true) {
		Radio1="Responsable No Inscripto"
	}
}
donde "Insc" es el nombre de instancia para el radiobutton de Responsable Inscripto, y "NoInsc" el nombre de instancia para el de No Inscripto. (Deben tener nombre de instancia)

si las variables del formulario se hubieran pasado a otro nivel, por ejemplo al _root, antes del envío al php, ten encuenta que donde dice Radio1 debes poner la ruta completa.

Recuerda: Radio1 en este script es un nombre de variable. No tiene nada que ver con el nombre del grupo de radiobuttons. Es más, por prolijidad te conviene cambiarlo para no confundirte. Yo utilicé ese nombre de variable para que no tengas que modificar tu php.

Por último, seguramente hay maneras más abreviadas y eficientes de hacer esto, pero como ya te dije, mi manejo de radiobuttons es nulo hasta el momento.

Saludos y cuéntame cómo te ha ido

el_leon
[email protected]
__________________________
la web la hacemos entre todos
__________________
el_leon
[email protected]
____________________________
la web la hacemos entre todos

Última edición por el_leon; 23/12/2003 a las 12:30
  #3 (permalink)  
Antiguo 23/12/2003, 12:48
Avatar de conic  
Fecha de Ingreso: marzo-2003
Ubicación: Buenos Aires
Mensajes: 108
Antigüedad: 14 años, 8 meses
Puntos: 6
Pues sabes que no tengo suerte. Seleccioné los dos radio buttons como me dijiste y los convertí en símbolo ->Movie Clip.
Una vez hecho esto volví a la escena principal donde está el formulario, seleccioné la MC y le di la accion que me pasaste, pero finalmente lo pruebo y en el mail el campo me llega en blanco
En el php estará el problema? Como te dije antes lo pido con:

Iva Resp Inscripto: $Radio1\n

Me faltará cambiar algo ahí o me equivoqué en alguna cosa desde el flash... el resto como te dije antes anda bien.

Espero tu respuesta y muchas gracias!!!
__________________
:-D ] CoNic [
  #4 (permalink)  
Antiguo 23/12/2003, 13:15
Avatar de el_leon  
Fecha de Ingreso: diciembre-2003
Ubicación: Buenos Aires, Argentina
Mensajes: 182
Antigüedad: 14 años
Puntos: 0
sucede que como no sé de qué forma están estructurados los campos, ni en qué nivel de la peli está el botón que hace el getURL, no sé cuál es la ruta donde poner la variable con el resultado del radiobutton.

por las dudas, en el mc que creaste con las acciones que te dí, reemplaza "Radio1" por "_parent.Radio1". Si no funciona, envíame el .fla a mi correo y lo reviso, porque sin ver las rutas no puedo ayudarte. También sería interesante saber cómo es el getURL que llama al .php

saludos

el_leon
[email protected]
___________________________
la web la hacemos entre todos
__________________
el_leon
[email protected]
____________________________
la web la hacemos entre todos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:28.