Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con rutas en Flash

Estas en el tema de Problema con rutas en Flash en el foro de Flash y Actionscript en Foros del Web. Hola tengo un movie clip dentro de otro movieclip. Para referirme al primer movieclip desde el segundo utilizo _root, y me funciona bien. Sin embargo, ...
  #1 (permalink)  
Antiguo 24/04/2012, 11:14
 
Fecha de Ingreso: febrero-2012
Mensajes: 12
Antigüedad: 10 años, 3 meses
Puntos: 0
Problema con rutas en Flash

Hola tengo un movie clip dentro de otro movieclip. Para referirme al primer movieclip desde el segundo utilizo _root, y me funciona bien. Sin embargo, cuando quiero referirme al escenario principal desde el primer movieclip utilizo _root y no me sirve, utilizo _root._root y tampoco. Cual seria la ruta correcta? Muchas gracias por su tiempo.
  #2 (permalink)  
Antiguo 24/04/2012, 11:19
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 18 años, 10 meses
Puntos: 406
Respuesta: Problema con rutas en Flash

Hola fiore_val:
Al decir:
Cita:
Para referirme al primer movieclip desde el segundo utilizo _root, y me funciona bien
Estás en un error.
Para referirte desde cualquier MC anidado a la Linea de tiempo principal se usa: _root en tu caso si quieres ir al primer MC desde el segundo debes de usar: _parent.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 24/04/2012, 11:30
 
Fecha de Ingreso: febrero-2012
Mensajes: 12
Antigüedad: 10 años, 3 meses
Puntos: 0
Respuesta: Problema con rutas en Flash

Que bueno que me contestaste Bandit. Mira segui tu "tutorial" para hacer botones que al hacer click se vean como presionados.

http://www.forosdelweb.com/f16/como-hacer-para-que-botonera-quede-marcado-boton-que-estoy-829546/

Bueno lo unico que los movie clip de los botones los hice dentro de otro movieclip que los agrupa a todos. Entonces en tu codigo tu usas el root para referirte a un nivel inferior que en el caso que pensaste tu debe ser el escenario principal. Bueno pero yo en el nivel inferior tengo otro movieclip que hago?

Ya lo cambie a _root pero no pasa nada. Mira este es el codigo que le puse al boton 1 (movieclip):

on(release){
gotoAndStop(2);
_parent.btn_1.gotoAndStop(1);
_root.btn_1.gotoAndStop(10);
}
se supone que cuando se presione el boton me debe llevar al fotograma 10 del escenario principal. Pero no me esta funcionando.
  #4 (permalink)  
Antiguo 24/04/2012, 17:51
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 18 años, 10 meses
Puntos: 406
Respuesta: Problema con rutas en Flash

Como tienes 2 MC anidados, estos deben de tener sus propio nombrs de instancia, los cuales deben ser referidos en el código
Si cada boton debe de regresar al primer frame éste código que publicas está mal, en las 2 últimas líneas:
Código actionscript:
Ver original
  1. on(release){
  2.    gotoAndStop(2);
  3.    _parent.btn_1.gotoAndStop(1);
  4.    _root.btn_1.gotoAndStop(10);
  5. }
porque los 2 deben de apuntar al _root y al frame 1.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 27/04/2012, 14:16
 
Fecha de Ingreso: febrero-2012
Mensajes: 12
Antigüedad: 10 años, 3 meses
Puntos: 0
Busqueda Respuesta: Problema con rutas en Flash

Ya solucione el problema gracias.

Última edición por fiore_val; 27/04/2012 a las 14:38 Razón: Ya solucione el problema.

Etiquetas: actionscript2, flash, ruta
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:45.