Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con sendAndLoad

Estas en el tema de Problema con sendAndLoad en el foro de Flash y Actionscript en Foros del Web. Hola: estoy teniendo un problema con el comando sendAndLoad. Mi aplicacion llama a una web que responde con un xml que lo cargo en la ...
  #1 (permalink)  
Antiguo 02/07/2007, 22:48
 
Fecha de Ingreso: febrero-2004
Mensajes: 40
Antigüedad: 13 años, 9 meses
Puntos: 0
Problema con sendAndLoad

Hola:
estoy teniendo un problema con el comando sendAndLoad. Mi aplicacion llama a una web que responde con un xml que lo cargo en la variable receiverLogin, de la forma:

login.sendAndLoad(login_url,receiverLogin,"POST");

donde login es un LoadVars y login_url es la direccion web. El tema es que cuando lo ejecuto desde flash(Ctrl+Enter) funciona perfecto. Pero cuando intento correrlo dentro de un html, no pareciera funcionar... Pareciera como que no llama a la pagina web....
Se les ocurre algo?

Gracias
  #2 (permalink)  
Antiguo 03/07/2007, 12:23
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: Problema con sendAndLoad

podria ser que usas ruta absoluta para llamar al php por ejemplo http://www...
y no una relativa.
  #3 (permalink)  
Antiguo 04/07/2007, 08:45
 
Fecha de Ingreso: febrero-2004
Mensajes: 40
Antigüedad: 13 años, 9 meses
Puntos: 0
Re: Problema con sendAndLoad

Gracias... es algo de eso...
Al parecer flash no soporta usar ese metodo en dominios diferentes. Para poder hacerlo se usa algo que se llama cross-domain y que estoy averiguando.

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:29.