Foros del Web » Creando para Internet » Flash y Actionscript »

problema con sonido....

Estas en el tema de problema con sonido.... en el foro de Flash y Actionscript en Foros del Web. Hola tengo un clip para reproducir y parar sonido, es una canción de unos 3 minutos, el problema que tengo es que aunque he importado ...
  #1 (permalink)  
Antiguo 04/12/2006, 13:58
 
Fecha de Ingreso: noviembre-2002
Mensajes: 571
Antigüedad: 15 años, 1 mes
Puntos: 2
problema con sonido....

Hola tengo un clip para reproducir y parar sonido, es una canción de unos 3 minutos, el problema que tengo es que aunque he importado la canción se supone que entera (insertarla en la línea de tiempo) cuando lleva 1 minuto y pico se reinicia, he mirado en editar sonido y las barras que sirven para editar el sonido, la de la derecha solo me deja deslizarla hasta el frame 3000, quedando mucho más sonido atenuado por lo que supongo que no se redroduce..., como puedo solucionarlo???

Gracias. Un saludo.
  #2 (permalink)  
Antiguo 04/12/2006, 14:22
Avatar de roc2107
ɹopɐɹǝpoɯ
 
Fecha de Ingreso: febrero-2003
Ubicación: León Guanajuato
Mensajes: 4.834
Antigüedad: 14 años, 9 meses
Puntos: 109
No la importes en la linea del tiempo, llamala de manera externa.

Saludos.
__________________
Blog de Diseño Gráfico roc21.com || Exámenes

El secreto de la creatividad es saber esconder tus fuentes.
  #3 (permalink)  
Antiguo 04/12/2006, 14:28
 
Fecha de Ingreso: noviembre-2006
Mensajes: 12
Antigüedad: 11 años
Puntos: 0
En lugar de insertarla en tu línea de tiempo principal por que no lo haces de manera externa???.
1. En un archivo nuevo de flash (no importa tamaño) insertas tu canción en el frame #1 (no necesitas más frames) y tu decides si la dejas como loop o que sólo suene una vez (eso lo haces en la barra de propiedades)
2. Este archivo lo exportas como swf (ejemplo: sonido.swf)
3. Le dices a tu botón que te llame ese archivo por níveles, ej:
on (release) {
loadMovieNum("sonido.swf", 10);
}
4. Si necesitas detenerlo le colocas a tu botón:
on (release) {
unloadMovieNum(10);
}
5. Voalá
  #4 (permalink)  
Antiguo 04/12/2006, 19:17
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola zertiko:
Carga tu sonido externamente colocando éste código en el primer frame de tu película.
son = new Sound();
son.loadSound("sonido.mp3", true);
son.start(0, 9999);
son.onSoundComplete = function() {
son.start(0, 1);
};

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 06/12/2006, 14:46
 
Fecha de Ingreso: noviembre-2002
Mensajes: 571
Antigüedad: 15 años, 1 mes
Puntos: 2
Re: problema con sonido....

Gracias, a todos por la ayuda, lo he cargado externamente y funciona sin problemas.

Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:53.