Foros del Web » Creando para Internet » Flash y Actionscript »

problema con sonido en botones

Estas en el tema de problema con sonido en botones en el foro de Flash y Actionscript en Foros del Web. necesito la ayuda de ustedes por favor. Estoy realizando un multimedia en flash de un portafolio de audios. Al darle clci al nombre del audio ...
  #1 (permalink)  
Antiguo 26/09/2008, 09:54
 
Fecha de Ingreso: septiembre-2008
Mensajes: 2
Antigüedad: 9 años, 2 meses
Puntos: 0
problema con sonido en botones

necesito la ayuda de ustedes por favor. Estoy realizando un multimedia en flash de un portafolio de audios. Al darle clci al nombre del audio este suena, pero lo que deseo es que al darle clic al nombre de otro audio suene pero que pare de sonar el audio anterior al que le di clic para que no se mezclen los audios. Como hago? ayundenme por favor
  #2 (permalink)  
Antiguo 26/09/2008, 12:45
 
Fecha de Ingreso: septiembre-2003
Ubicación: Capital Federal
Mensajes: 38
Antigüedad: 14 años, 3 meses
Puntos: 0
Respuesta: problema con sonido en botones

Hola Emilio Jose,
Mirá la forma mas facil que se me ocurre en primera instancia en que utilices stopAllSounds. No se como está armada tu animación pero si cada botón tiene un sonido lo que podrías hacer antes de que inicie el sonido es poner una acción con stopAllSounds, eso detendría el audio anterior y dejaria que corriera el nuevo, es decir, el que tiene el boton al que le estás dando click.
El sonido de los botones deberías ponerlo en el fotograma siguiente del que se encuentre la acción, de lo contrario no la correría.
Bueno, espero que te ayude el comentario.

Slds,
Josea
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:12.