Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con Sonido al Cargar una Pelicula

Estas en el tema de Problema con Sonido al Cargar una Pelicula en el foro de Flash y Actionscript en Foros del Web. Tengo una Pelicula principal, en la cual cargo un archivo que se llama sonido.swf , en sonido.swf tengo un sonido a cargar, con una animacion. ...
  #1 (permalink)  
Antiguo 16/09/2006, 18:44
 
Fecha de Ingreso: septiembre-2004
Ubicación: Cordoba
Mensajes: 70
Antigüedad: 13 años, 3 meses
Puntos: 0
Problema con Sonido al Cargar una Pelicula

Tengo una Pelicula principal, en la cual cargo un archivo que se llama sonido.swf , en sonido.swf tengo un sonido a cargar, con una animacion.
Resulta que cuando cargo el sonido.swf a la pelicula principal, me carga perfectamente la pelicula (se ve la animacion), pero no sale el sonido, en el script de sonido.swf tengo el siguiente codigo ya que es muy basico.
Código PHP:
mi_sound = new Sound();
mi_sound.attachSound("tema" );
mi_sound.start(0,999); 
Tengo activadas la propiedades de vinculacion en el sonido:
Identificador: tema
Exportar para ActionScript
Exportar en Primer Fotograma

Si yo pruebo por separado la pelicula sonido.swf anda perfectamente sale el sonido se comporta como yo deseo, pero cuando lo cargo a sonido.swf mediante una pelicula principal reitero solamente sale la animacion y el sonido no, que puede pasar?? el sonido no se adapta a la opcion loadmovie?? desde ya muchas gracias y saludos
__________________
HACER LA GUERRA PARA DEFENDER LA PAZ, ES COMO HACER UNA ORGIA PARA DEFENDER LA VIRGINIDAD
  #2 (permalink)  
Antiguo 17/09/2006, 11:52
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola ELLUIFA:
Importa a la biblioteca de la principal tu sonido.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 17/09/2006, 19:05
 
Fecha de Ingreso: septiembre-2004
Ubicación: Cordoba
Mensajes: 70
Antigüedad: 13 años, 3 meses
Puntos: 0
Ok, a eso ya lo habia pensado, pero lo quiero evitar, pues quiero que la pelicula princial se cargue rapidamente ya que pesa 82 kb, y el sonido se cargue aparte que pesa 306 kb. No se puede hacer como yo lo quise Hacer??? poniendo el audio en una pelicula secundaria y despues cargarlo en la principal y de la forma q yo lo quiero hacer???. desde ya gracias.
__________________
HACER LA GUERRA PARA DEFENDER LA PAZ, ES COMO HACER UNA ORGIA PARA DEFENDER LA VIRGINIDAD
  #4 (permalink)  
Antiguo 18/09/2006, 10:17
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Parece que no entendiste, si estás attachando el sonido en la otra película tienes que ponerlo el sonido en la biblioteca de la principal, para que al cargar la película sonido.swf se pueda escuchar.

Esopero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 18/09/2006, 16:50
 
Fecha de Ingreso: septiembre-2004
Ubicación: Cordoba
Mensajes: 70
Antigüedad: 13 años, 3 meses
Puntos: 0
Si te entendi muchas gracias, pero al poner el attachment en la pelicula principal por ende aumento el tamaño de mi pelicula principal, y eso es lo que no quiero por va a tener q ser la unica solucion, saludos y desde ya gracias.
__________________
HACER LA GUERRA PARA DEFENDER LA PAZ, ES COMO HACER UNA ORGIA PARA DEFENDER LA VIRGINIDAD
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:58.