Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con sonido en Flash

Estas en el tema de Problema con sonido en Flash en el foro de Flash y Actionscript en Foros del Web. Buenas! Estoy creando una web en flash y he insertado un sonido de fondo. Parece que está todo bien, pero al hacer "Probar Película" me ...
  #1 (permalink)  
Antiguo 12/08/2008, 12:57
 
Fecha de Ingreso: agosto-2008
Mensajes: 12
Antigüedad: 9 años, 4 meses
Puntos: 0
Problema con sonido en Flash

Buenas!

Estoy creando una web en flash y he insertado un sonido de fondo. Parece que está todo bien, pero al hacer "Probar Película" me aparece el siguiente mensaje de error:

El sonido no dispone de ruta de sonido del dispositivo válida a pesar de que en la configuración de la exportación se solicitó la exportación de sonidos de dispositivos. Se omitirá el sonido.

¿Alguien puede ayudarme? Advierto que soy bastante novata en el tema ;)

Gracias y hasta pronto!
  #2 (permalink)  
Antiguo 12/08/2008, 13:31
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema con sonido en Flash

Hola mgasion:
Bienvenida al Foro.
Porque no muestras el código que haz usado para el sonido.

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 12/08/2008, 15:37
 
Fecha de Ingreso: agosto-2008
Mensajes: 12
Antigüedad: 9 años, 4 meses
Puntos: 0
Respuesta: Problema con sonido en Flash

Hola Bandit, gracias por el interés! :)

Te refieres al código en el ActionScript???

- He creado una capa donde he puesto el .mp3, permitiendo la exportación para ActionScript con el Id. "sonido"
- He creado otra capa con un .gif que he convertido en símbolo - botón, con la instancia "play_btn".
- Y por último, una última capa donde he puesto el código AS, que es el siguiente:

my_sound = new Sound();
my_sound.attachSound("sonido");

play_btn.onPress = function() {
my_sound.start();
}


Para el botón stop he hecho lo mismo pero el botón con la instancia "stop_btn" y el código de AS es este:

stop_btn.onPress = function() {
my_sound.stop("sonido");
}

Lo más "gracioso" de todo es que la primera vez que lo he hecho me ha funcionado perfectamente, pero he cerrado el archivo y al volverlo a abrir ya no funcionaba... no sé si he tocado algo que no debía o el qué, pero he probado a borrar todo y hacerlo desde cero y ya no me sale! qué desastre...

Espero me podáis ayudar, gracias!!!
  #4 (permalink)  
Antiguo 12/08/2008, 19:02
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema con sonido en Flash

Hola mgasion:
Sería mejor que lo cargues externamente el sonido, de ese modo evitas aumentar de peso a tu película.
En el primer frame de tu pelicula coloca éste código:
son = new Sound();
son.loadSound("ru_sonido.mp3", true);
son.onSoundComplete = function() {
son.start(0, 1);
};
play_btn.onPress = function() {
son.start();
}
stop_btn.onPress = function() {
son.stop();
}
El sonido lo guardas en la carpeta donde está ru película.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:40.