Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con swf carga dentro de un MC pero sin lo datos de XML

Estas en el tema de Problema con swf carga dentro de un MC pero sin lo datos de XML en el foro de Flash y Actionscript en Foros del Web. Buenas tardes para [email protected] He buscando y he probado varias cosas pero no encuentro la solucion, loq ue pasa es que estoy desarrollando mi portafolio, ...
  #1 (permalink)  
Antiguo 23/10/2009, 10:06
Avatar de Yeigp  
Fecha de Ingreso: diciembre-2006
Ubicación: Manizales-Colombia
Mensajes: 132
Antigüedad: 14 años, 4 meses
Puntos: 0
Problema con swf carga dentro de un MC pero sin lo datos de XML

Buenas tardes para [email protected]

He buscando y he probado varias cosas pero no encuentro la solucion, loq ue pasa es que estoy desarrollando mi portafolio, y tego el swf principal y dentro de este cargan 4 swf dentro de 4 MovieClips diferentes, hasta ahi todo perfecto.

El problema es que cuando cargo uno de estos swf ,este tiene una programacion especifica es algo que me baje para hacer una dynamic 3s wall gallery pero al cargar este swf que contiene la galeria no me carga ninguna de las imagenes ni datos que debe traer desde un xml.

No se como solucionar esto, la verdad no soy un experto en flash y de verdad lo necesito si me pueden ayudar se los agradeceria.
Gracias de antemano a cualquiera que se interese en ayudarme
  #2 (permalink)  
Antiguo 23/10/2009, 10:14
Avatar de Lynxcraft  
Fecha de Ingreso: noviembre-2007
Ubicación: yecla murcia
Mensajes: 1.346
Antigüedad: 13 años, 5 meses
Puntos: 51
Respuesta: Problema con swf carga dentro de un MC pero sin lo datos de XML

primero si tienes los swf en otra carpeta es un problema de rutas para que no tengas problemas coloca en los codigos de carga la ruta completa acia el archivo que vas a cargar por ejemplo


http://www.miweb.com/carpeta/miarchivo.xml

y si el xml tiene como valores de carga sin la ruta completa añadirlos también ejemplo


<contenido>
<img> http://www.miweb.com/carpeta/img1.jp</img>
</contenido>

es lo mas sencillo que puedes hacer es un poco engorroso XDXD otra solución es mas complicada de explicar si no sabes mucho de programación XDXD
__________________
Sobran las ideas cuando faltan ganas de trabajar en ellas
Lynxcraft
  #3 (permalink)  
Antiguo 23/10/2009, 10:56
Avatar de Yeigp  
Fecha de Ingreso: diciembre-2006
Ubicación: Manizales-Colombia
Mensajes: 132
Antigüedad: 14 años, 4 meses
Puntos: 0
Respuesta: Problema con swf carga dentro de un MC pero sin lo datos de XML

Hola gracias por tu pronta respeusta
pues es que el swf si me carga pero no me cargar es por ejemplo la galleria de imagenes, que llama los archivos desde xml..
no soy un muy ducho pero comprendo algo del codigo de programación.

se me ocuure otra pregunta, es posible que el swf que llama a los otro este hecho con AS2 y los que carguen esten con AS3 o esto genera problemas?

muchas gracias de verad por su ayuda porque estoy hecho una bola y no s eocmo solucionarlo y por conveniencia de administraciond e mi porotafolio obviamente es mas sencillo cargando cosas externametne.

Gracias!!!!!!!!!!!!!!!!
  #4 (permalink)  
Antiguo 23/10/2009, 11:04
Avatar de Lynxcraft  
Fecha de Ingreso: noviembre-2007
Ubicación: yecla murcia
Mensajes: 1.346
Antigüedad: 13 años, 5 meses
Puntos: 51
Respuesta: Problema con swf carga dentro de un MC pero sin lo datos de XML

jejej Pos si... no es posible llamar archivos AS3 desde el AS2 XDXD

Al contrario se puede pero suele dar muchos problemas
__________________
Sobran las ideas cuando faltan ganas de trabajar en ellas
Lynxcraft
  #5 (permalink)  
Antiguo 30/10/2009, 07:16
Avatar de Yeigp  
Fecha de Ingreso: diciembre-2006
Ubicación: Manizales-Colombia
Mensajes: 132
Antigüedad: 14 años, 4 meses
Puntos: 0
Respuesta: Problema con swf carga dentro de un MC pero sin lo datos de XML

OK, gracias
pero probe con dos archivos con AS2 y tampoco me permite me sigue persistiendo el mismo problema.

Me pueden hechar una manito o darme una guia de que puede ser.
gracias de verdad
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:44.