Foros del Web » Creando para Internet » Flash y Actionscript »

Problema con versiones del Flash

Estas en el tema de Problema con versiones del Flash en el foro de Flash y Actionscript en Foros del Web. Hola a todos Tengo un problemilla, vereis, estoy realizando la página web para la empresa donde trabajo ( sgbrand.com ) pero tengo unos problemillas con ...
  #1 (permalink)  
Antiguo 08/09/2006, 05:48
uen
 
Fecha de Ingreso: octubre-2003
Ubicación: A Coruña
Mensajes: 55
Antigüedad: 14 años, 1 mes
Puntos: 0
Mensaje Problema con versiones del Flash

Hola a todos

Tengo un problemilla, vereis, estoy realizando la página web para la empresa donde trabajo ( sgbrand.com ) pero tengo unos problemillas con los flash que hay en la web.

Estan hechos en Flash 8 y programados para que funcionen correctamente con la version 8 del flash player o superior (actualmente creo que esta en la 9). El problema esta si el usuario tiene una version menor a la 8. He intentado "publicar" mi proyecto con la version 7 del player pero me da un monton de errores.

Mi pregunta es la siguiente: existe algún comando de lo que sea (actionscripct, javascript, php,... ) que detecte la version que tiene la persona que visita la página y si es menor que la versión 8 le avise de que la presentación no se verá correctamente y que puede descargarse la nueva versiond e tal sitio, o algo por el estilo ?

O alguna otra idea si teneis. Ya aprobechando el post, si me podriais decir que os parece la página y algun consejillo

Saludos a todos, y gracias anticipadamente
__________________
We Create, They Destroy Me.
  #2 (permalink)  
Antiguo 08/09/2006, 06:57
 
Fecha de Ingreso: diciembre-2005
Ubicación: Redondela (Galicia)
Mensajes: 368
Antigüedad: 12 años
Puntos: 1
¿Qué tal se te da el inglés?

http://blog.deconcept.com/swfobject/

El SWFObject (antes FlashObject) sirve para eliminar el marco gris que aparece alrededor de los swf en el explorer y que obliga a "hacer un click para activarlos". Tú le debes especificar en uno de los argumentos de la función que inserta el swf qué versión como mínimo ha de tener el cliente, por lo que si no la tiene muestra el contenido alternativo.

Ojo que el cliente debe tener JavaScript para que el SWFObject funcione.
  #3 (permalink)  
Antiguo 08/09/2006, 09:18
uen
 
Fecha de Ingreso: octubre-2003
Ubicación: A Coruña
Mensajes: 55
Antigüedad: 14 años, 1 mes
Puntos: 0
muchas gracias !! era lo que estaba buscando! aparte lo de eliminar el dichoso marco gris me sacaba de quicio, mato dos pajaros d eun tiro, muchas gracias !!
te debo una caña xD
__________________
We Create, They Destroy Me.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:11.