Foros del Web » Creando para Internet » Flash y Actionscript »

Problema conLoadSound

Estas en el tema de Problema conLoadSound en el foro de Flash y Actionscript en Foros del Web. Tengo una capa con varias instancias para los diferente apartados de la web, quienes somos, trabajos etc....y encima he puesto una capa para el sonido ...
  #1 (permalink)  
Antiguo 23/12/2005, 04:52
Avatar de alexander_sp  
Fecha de Ingreso: febrero-2004
Ubicación: Barcelona
Mensajes: 694
Antigüedad: 13 años, 9 meses
Puntos: 4
Problema conLoadSound

Tengo una capa con varias instancias para los diferente apartados de la web, quienes somos, trabajos etc....y encima he puesto una capa para el sonido con el siguiente script en el 1 frame;

mimusica= new Sound()
mimusica.loadSound("sofa.mp3",true)
function comenzar(){
mimusica.start(0,999)
}
mimusica.onLoad = comenzar()

El problema es que solo se reproduce una sola vez;
sabeis cual puede ser el motivo?
Merci y un saludo a todos y feliz navidad
  #2 (permalink)  
Antiguo 23/12/2005, 07:44
Avatar de Mauri1  
Fecha de Ingreso: noviembre-2002
Ubicación: Santiago de Chile
Mensajes: 558
Antigüedad: 15 años
Puntos: 0
Prueba con esto

Código:
 
mimusica = new Sound();
mimusica.loadSound("sofa.mp3", true);
mimusica.start();
mimusica.onSoundComplete = function() {
 mimusica.start();
};

Última edición por Mauri1; 23/12/2005 a las 09:59
  #3 (permalink)  
Antiguo 23/12/2005, 08:28
Avatar de alexander_sp  
Fecha de Ingreso: febrero-2004
Ubicación: Barcelona
Mensajes: 694
Antigüedad: 13 años, 9 meses
Puntos: 4
Cojonudo

Muchas gracias, va de coña.
un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:44.