Foros del Web » Creando para Internet » Flash y Actionscript »

Problema extraño (sólo uno más)

Estas en el tema de Problema extraño (sólo uno más) en el foro de Flash y Actionscript en Foros del Web. Estimados foreros: Voy a relatarles un problema extraño que estoy teniendo, solo uno más de los miles que tuve que afrontar. Hize un panel en ...
  #1 (permalink)  
Antiguo 26/02/2008, 10:06
 
Fecha de Ingreso: diciembre-2007
Mensajes: 467
Antigüedad: 10 años
Puntos: 3
Problema extraño (sólo uno más)

Estimados foreros:

Voy a relatarles un problema extraño que estoy teniendo, solo uno más de los miles que tuve que afrontar.
Hize un panel en Flash con dos campos. Esos campos son usuario y contraseña. Los datos se envian a un PHP que los compara con datos de una base mysql y devuelve OK en caso de que sean iguales y NOOK si no lo son.
Esto venía funcionando perfecto, sin el menor problema hasta hoy. Hoy intento ingresar al panel y me dice que los datos son incorrectos, es decir, el PHP devuelve NOOK o cualquier otra cosa pero no devuelve OK.
Hace días que no toco los archivos del servidor y sin embargo, el comportamiento del sistema ha cambiado de un momento para otro.
Alguien tiene idea de qué puede estar pasando???
Muchas gracias.


Federico
  #2 (permalink)  
Antiguo 26/02/2008, 11:22
 
Fecha de Ingreso: diciembre-2007
Mensajes: 467
Antigüedad: 10 años
Puntos: 3
Re: Problema extraño (sólo uno más)

Estimados Foreros:

Creo saber lo que pasa, pero me gustaría recibir opiniones de ustedes.
El problema no es que estoy recibiendo un NOOK, si este fuera el caso, me preocuparía puesto que los datos son correctos y el PHP debería devolver un OK.
El asunto es que en el archivo Flash puse una linea if (variable.respuesta == "OK") y luego hice un ELSE, es decir, no hice un if (variable.respuesta == "NOOK")
La conclusión es: no estoy recibiendo un NOOK sino que, sencillamente, estoy recibiendo algo distinto a OK, por eso, el programa entra por el ELSE y me dice que los datos no son correctos.
Esto me hizo pensar que no estoy recibiendo bien la respuesta del archivo PHP. Así que hice la siguiente prueba: cargué un archivo PHP en el servidor con una línea echo y también cargué un htm en la misma carpeta con un texto simple. El htm se muestra pero el PHP no. Lo que ocurre con el PHP es que me aparece la ventana de descarga de archivo, es decir, el servidor está fallando para archivos PHP.
Lo que quiero saber es si estoy razonando bien el problema y, de ser así, si es común que un servidor falle para un tipo de archivo y no para otros.
Muchas gracias.



Federico
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:34.