Foros del Web » Creando para Internet » Flash y Actionscript »

Problema al insertar Swf externo en *.fla

Estas en el tema de Problema al insertar Swf externo en *.fla en el foro de Flash y Actionscript en Foros del Web. Hola, me gustaría saber como puedo corregir el siguiente problema: Me salen las letras exteriores del swf, como puedo hacer que desaparezcan, con una mascara ...
  #1 (permalink)  
Antiguo 25/06/2008, 17:46
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Exclamación Problema al insertar Swf externo en *.fla

Hola, me gustaría saber como puedo corregir el siguiente problema:

Me salen las letras exteriores del swf, como puedo hacer que desaparezcan, con una mascara o algo?

Esque no ha sido en la propia película, sino insertando un SWF en un MovieClip con el siguiente código:

Código:
clip_mc = this.createEmptyMovieClip("holder", 1);
clip_mc._x = 53;
clip_mc._y = 388.2;
clip_mc.loadMovie("flash01.swf")
Podeis verlo en:

http://www.torina.it/problema.html

Al entrar, dar a "EMPRESA"
  #2 (permalink)  
Antiguo 25/06/2008, 19:05
 
Fecha de Ingreso: diciembre-2004
Mensajes: 418
Antigüedad: 13 años
Puntos: 2
Respuesta: Problema al insertar Swf externo en *.fla

mmm, creoq te complicarias menos, si crearas manulamente un mc vacio. dale un nombre de instancia y le aplicas el loadmovie (ya manualmente le das la posicion correcta al mc). de salirte ya podras aplicarle directamente una mascara.

Saludos
__________________
Veo de todo un poco, pero siempre tengo mis favoritos xD. No subestimen a Flash!
  #3 (permalink)  
Antiguo 26/06/2008, 00:26
Avatar de calinsito  
Fecha de Ingreso: enero-2007
Ubicación: Guatemala
Mensajes: 168
Antigüedad: 10 años, 10 meses
Puntos: 2
Respuesta: Problema al insertar Swf externo en *.fla

Hey NaRanJiTo78

nade mejor que una mascara a esa pelicula swf externa, para evitarte tanto problema
pero al ir al area de contacto debes darle un

unloadmovie

ya que se queda sobre el area de contacto

diviertete
__________________
amor a primera vista, animacion flash para la web
  #4 (permalink)  
Antiguo 28/06/2008, 16:44
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

la mascara no me funciona, será porque al ser una insercion de un swf en un fla es distinto?
  #5 (permalink)  
Antiguo 28/06/2008, 18:32
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema al insertar Swf externo en *.fla

Hola NaRanJiTo78:
Así como te dijo calinsito, abre la película: "flash01.fla", crea una capa superior y allí dibujando un rectángulo del tamaño del escenario, a ésta capa la conviertes en máscara.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #6 (permalink)  
Antiguo 29/06/2008, 05:38
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

El problema esque no consigo que se muestre la capa, como podeis ver en ésta imagen:



Porque ocurre o que es en lo que me estoy equivocando??

Muchas gracias
  #7 (permalink)  
Antiguo 29/06/2008, 05:59
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

La anterior foto mostyraba una máscara de prueba para ver si se podía quitar un lado con la máscara, en cambio, como dice Bandit, si se la aplico a el tamaño de la película entera tampoco:



Porqué???
  #8 (permalink)  
Antiguo 29/06/2008, 07:46
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

Ya he solucionado el tema de la máscara!!!

Lo único que no me funciona el unloadmovie, calinsito:

Cita:
Iniciado por calinsito Ver Mensaje
Hey NaRanJiTo78

nade mejor que una mascara a esa pelicula swf externa, para evitarte tanto problema
pero al ir al area de contacto debes darle un

unloadmovie

ya que se queda sobre el area de contacto

diviertete
Cómo lo debo de poner??

En acciones tengo: unloadmovie (flash01.swf)

Éste fotograma donde vá?al inicio de contacto?

Muchas gracias
  #9 (permalink)  
Antiguo 29/06/2008, 11:25
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema al insertar Swf externo en *.fla

Como haz cargado tu película así: clip_mc.loadMovie("flash01.swf") en el resto de los botones adiciona éste código: clip_mc.unloadMovie();

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #10 (permalink)  
Antiguo 29/06/2008, 12:03
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

Es decir, en el Botón Actividad y Contacto poner esas acciones??

O en el clip de película?

Muchas Gracias
  #11 (permalink)  
Antiguo 29/06/2008, 12:17
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
Respuesta: Problema al insertar Swf externo en *.fla

SOLUCIONADO, Bandit. Mil gracias.

Ahí va tu karma ;)
  #12 (permalink)  
Antiguo 29/06/2008, 12:19
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema al insertar Swf externo en *.fla

Aquí está bien claro:
Cita:
en el resto de los botones adiciona éste código: clip_mc.unloadMovie();
.
Cuales son los otros botones, no son: ACTIVIDAD Y CONTACTO?

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #13 (permalink)  
Antiguo 29/06/2008, 12:26
Avatar de NaRanJiTo78  
Fecha de Ingreso: noviembre-2007
Ubicación: In the BeaCh
Mensajes: 874
Antigüedad: 10 años
Puntos: 10
De acuerdo Respuesta: Problema al insertar Swf externo en *.fla

Si, ya lo vi, justo cuando estabas contestando debí de hacerlo yo tambien(el contestarte, pues te di las gracias antes de tu post)...

MUCHISIMAS GRACIAS
  #14 (permalink)  
Antiguo 29/06/2008, 12:32
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema al insertar Swf externo en *.fla

Y nada, para eso estamos.

Saludos desde Perú.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:19.