Foros del Web » Creando para Internet » Flash y Actionscript »

problema on/off sonido en web flash

Estas en el tema de problema on/off sonido en web flash en el foro de Flash y Actionscript en Foros del Web. Hola a [email protected], he estado mirando en el foro aún así y no me funciona lo que quiero. Estoy haciendo una web en flash, la ...
  #1 (permalink)  
Antiguo 16/06/2007, 09:58
 
Fecha de Ingreso: octubre-2006
Mensajes: 131
Antigüedad: 11 años, 2 meses
Puntos: 0
problema on/off sonido en web flash

Hola a [email protected], he estado mirando en el foro aún así y no me funciona lo que quiero. Estoy haciendo una web en flash, la cual va cargando .swf. En mi index he puesto el siguiente código para cargar el sonido de la web de forma externa:

sonido=new Sound();
sonido.loadSound("sonido_web.mp3",true);
sonido.start(0,9999);
sonido.onSoundComplete=function(){
sonido.start(0,1);
};

Mi problema es que estoy haciendo un botón que me permita desactivar y activar el sonido (pero haciendo un pause, no para que comience desde el principio el sonido), y al tener que cargar los .swf, en el codigo del botón he utilizado _root, para que apunte a la index (que es donde voy cargando los .swf).

El código que he puesto en mi botón es el siguiente:

on (release){
if( _root.sonido.getVolume==100){
_root.sonido.setVolume=0
}
else if(_root.sonido.getVolume==0){
_root.sonido.setVolume=100
}
};

Y cuando le doy al botón no me hace nadaaaaaaaa

Alguien sabe que estoy haciendo mal???
Muchas gracias. Salu2!

Última edición por Lavego; 16/06/2007 a las 10:55
  #2 (permalink)  
Antiguo 16/06/2007, 10:44
Avatar de sheshu  
Fecha de Ingreso: abril-2006
Ubicación: En too el medio
Mensajes: 160
Antigüedad: 11 años, 8 meses
Puntos: 0
Re: problema on/off sonido en web flash

hola,

parece un problema de sintaxis, prueba con este código:
Código:
if( _root.sonido.getVolume()==100){
_root.sonido.setVolume(0);
}
else if(_root.sonido.getVolume()==0){
_root.sonido.setVolume(100);
};
un saludo
__________________
sheshu ::: www.tutoriales-flash.com
  #3 (permalink)  
Antiguo 16/06/2007, 10:50
 
Fecha de Ingreso: octubre-2006
Mensajes: 131
Antigüedad: 11 años, 2 meses
Puntos: 0
Re: problema on/off sonido en web flash

Hola seshu, pues lo he probado y me ha funcionado a medias, jeje, me para el sonido pero si vuelvo a darle al botón no lo reanuda, se queda sin sonido...

Muchas gracias por tu ayuda.
Salu2!
  #4 (permalink)  
Antiguo 16/06/2007, 11:06
 
Fecha de Ingreso: octubre-2006
Mensajes: 131
Antigüedad: 11 años, 2 meses
Puntos: 0
Re: problema on/off sonido en web flash

Shesuuuuuuuuu eres un hachaa!! jajaja, era por eso, pq lo otro que no me volvia a ponerlo era pq me he equivocado yo, y en lugar de setVolume he vuelto a poner getVolume,jaja.

Muchas gracias men!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:19.