Foros del Web » Creando para Internet » Flash y Actionscript »

problema para activar botones?

Estas en el tema de problema para activar botones? en el foro de Flash y Actionscript en Foros del Web. hola, tengo un problema para activar botones, tengo un archivo prinicpal inicio el cual tiene 4 botones ( cada boton esta dentro de un mc ...
  #1 (permalink)  
Antiguo 04/02/2010, 13:49
Avatar de Verys  
Fecha de Ingreso: octubre-2008
Ubicación: Argentina
Mensajes: 48
Antigüedad: 12 años, 1 mes
Puntos: 1
problema para activar botones?

hola, tengo un problema para activar botones, tengo un archivo prinicpal inicio el cual tiene 4 botones (cada boton esta dentro de un mc porque tienen un efecto al pasar el mouse por arriba) cada uno llama en un nivel diferente loadMovieNum a su respectivo archivo, hasta ahi todo bien, el problema es que cuando cargan los niveles los botones del archivo principal (nivel cero) siguen activos, logre desactivarlos con este codigo:

este es solo un boton

Código:
on (release) { 
      loadMovieNum("mi.swf",4); 
      btnmi.enabled = false; 
}
le coloque este codigo al boton que cierra el nivel superior
Código:
unloadMovieNum(4); 
btnmi.enabled = true;
pero el boton no se activa queda como si estuviera presionado, no se como solucionarlo help plisss

es en as2

Saludos =)
__________________
Mi Blog
  #2 (permalink)  
Antiguo 06/02/2010, 13:07
Avatar de Verys  
Fecha de Ingreso: octubre-2008
Ubicación: Argentina
Mensajes: 48
Antigüedad: 12 años, 1 mes
Puntos: 1
Respuesta: problema para activar botones?

plis alguien

Saludos =)
__________________
Mi Blog
  #3 (permalink)  
Antiguo 06/02/2010, 13:12
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 17 años, 4 meses
Puntos: 406
Respuesta: problema para activar botones?

Hola Verys:
Si el botón está dentro de un MC, tendrás que ponerle un nombre de instancia a ese MC y en el código de cierre, tendrás que darle la ruta.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 07/02/2010, 09:30
 
Fecha de Ingreso: enero-2010
Mensajes: 25
Antigüedad: 10 años, 10 meses
Puntos: 1
Respuesta: problema para activar botones?

Esta perfecto lo que dijo Bandit. Para aclararlo un poco nomás:
le pones un nombre de instancia a tu clip (ej: "botonera") y al boton que cierras y quieres que vuelva a activar el btnmi le pones este codigo

on(release)
{
_root.botonera.btnmi.enabled=true
}
  #5 (permalink)  
Antiguo 08/02/2010, 13:22
Avatar de Verys  
Fecha de Ingreso: octubre-2008
Ubicación: Argentina
Mensajes: 48
Antigüedad: 12 años, 1 mes
Puntos: 1
Respuesta: problema para activar botones?

hola, gracias por responder, pero no funciona, nose si sera por el efecto rollover, este efecto es el que estoy usando

http://www.fishboneproductions.com/jadchor/

pero cuando desactivo el boton no puedo volver a activarlo, aunque le coloque la ruta que me dicen ustedes, no hay caso

_root.clip3.btnmi.enabled=true;

el boton queda como si estuviera presionado

por ahora la unica opcion que he encontrado es crear un boton grande en la carga externa y desactivarlo, se que no es la mejor opcion pero es la que funciona

Saludos =)
__________________
Mi Blog

Etiquetas: botones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:05.