Foros del Web » Creando para Internet » Flash y Actionscript »

problema al reproducir musica

Estas en el tema de problema al reproducir musica en el foro de Flash y Actionscript en Foros del Web. Hola, voy a intentar explicar el problema lo mejor que pueda. Tengo un listado de canciones que deseo reproducir, de momento 3, por lo que ...
  #1 (permalink)  
Antiguo 24/12/2008, 14:40
 
Fecha de Ingreso: diciembre-2006
Mensajes: 50
Antigüedad: 11 años
Puntos: 1
problema al reproducir musica

Hola, voy a intentar explicar el problema lo mejor que pueda.

Tengo un listado de canciones que deseo reproducir, de momento 3, por lo que he creado un boton llamado "sonido1", "sonido2" y "sonido3", estos tres botones en la misma capa llamada "botones", cada boton tiene el siguiente codigo,solo pongo el codigo del boton "sonido1":

on (release) {
stopAllSounds();
sonido_actual="s1";
s1.start();
s1.setVolume(vol);
ejecutando=1;
}

Luego vinculo las 3 canciones a los botones.

En una capa aparte llamada "scrips" pongo el siguiente codigo:

//CODIGO CAPA SCRIPS:

s1 = new Sound();
s1.attachSound("sonido1");
//
s2 = new Sound();
s2.attachSound("sonido2");
//
s3 = new Sound();
s3.attachSound("sonido3");
//
var sonido_actual = "s1";
var tiempo_actual = 1;
var ejecutando = 0;
//
tiempo.restrict = "0-9";
//
this.onEnterFrame = function() {
if (ejecutando == 1) {
total = Math.floor(eval(sonido_actual).duration/1000);
duracion = Math.floor(eval(sonido_actual).position/1000);
}
};

Todo funciona perfecto, pero ahora quiero incluir todos los botones en un clip de video, para probar he cogido solo dos botones y le doy a F8 y los transformo en clip de video llamado "clip", de modo que me quedan los dos botones insertados en un clip de video, pruebo de nuevo y ya no funciona, a excepcion del botón que excluí del clip de video.
Esto me da a entender que al transformarlos, debo poner algo mas como (_parent o _root) pero he probado y sigue igual, no se si van los tiros por ahí o no.

Espero haberme explicado bien y ha ver si me podeis dar consejos

Muchas gracias.
  #2 (permalink)  
Antiguo 03/01/2009, 16:16
 
Fecha de Ingreso: enero-2009
Mensajes: 34
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: problema al reproducir musica

primero... separa los botones en capas porque sino no funca la cosa.
segundo... porque no lo haces en diferentes escenas?? todas iguales pero con diferentes canciones, este es el script que debes introducir en el boton al ponerlo en la escena:

on(press){
gotoAndPlay("nombredeescena",1);
stopAllSounds
}

el stop all sounds no permite que se mezclen los sonidos y termines con terrible ensalada de musica
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:48.