Foros del Web » Creando para Internet » Flash y Actionscript »

Problema SWF y FLA

Estas en el tema de Problema SWF y FLA en el foro de Flash y Actionscript en Foros del Web. Hola foreros, hice un swf donde rotando 1 imagen luego se transforma en otra, en un frame del layer unico que tengo en la pelicula ...
  #1 (permalink)  
Antiguo 02/10/2008, 15:48
 
Fecha de Ingreso: marzo-2008
Mensajes: 37
Antigüedad: 9 años, 8 meses
Puntos: 0
Problema SWF y FLA

Hola foreros,

hice un swf donde rotando 1 imagen luego se transforma en otra, en un frame del layer unico que tengo en la pelicula principal puse un mc y este action script al frame:

velocidad=207.36; aceleracion=0.928;
imagen.onEnterFrame=function(){
imagen._rotation+=velocidad;
velocidad*=aceleracion;
}

dentro del mc 2 layers con fade out primera imagen y fade in para la segunda, hasta ahi todo corre biensisimo

El problema viene cuando quiero agrandar la pelicula principal, osea ponerles mas animaciones y demas, con otros layers y cosas, ya no gira la imagen, solo hace bien su animación cuando no hay nada mas en la pelicula principal, no lo puedo mover a otro frame ni nada, incluso la exporte como swf cuando me corria bien pero cuando trato de insertar ese swf en el fla que estoy haciendo me aparece como imagen bitmap y no como swf.

Seguro es alguna estupidez mía pero de todos modos se les agredecerá mucho su ayuda. Si necesitan mas detalles mi msn es [email protected]

Siempre agradecido por su ayuda.

Última edición por diegoba10; 02/10/2008 a las 15:53
  #2 (permalink)  
Antiguo 03/10/2008, 09:56
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema SWF y FLA

Hola diegoba10:
Lo que tienes que hacer es cargar esa película en la principal con: loadMovieNum(); o nombre_instancia_mc_vacio.loadMovie().

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 03/10/2008, 16:53
 
Fecha de Ingreso: marzo-2008
Mensajes: 37
Antigüedad: 9 años, 8 meses
Puntos: 0
Respuesta: Problema SWF y FLA

Hola Bandit,

te agradezco mucho tu ayuda y si que me sirvio, pero ahora tengo otro problema, cargo un swf arriba, otro al medio y otro abajo, como podras ver en esta página:

http://www.emprender.org/cambio.html

y los 3 tienen que comenzar al mismo tiempo, trate con precarga y todo pero nada, apenas se va cargando 1 lo muestra y se desfasa todo, porque si o si tienen que comenzar todos al mismo tiempo.

Ojalá me puedas ayudar en esto, gracias de antemano.
  #4 (permalink)  
Antiguo 04/10/2008, 10:05
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problema SWF y FLA

Las películas se cargarán rápido o lento, dependiendo de su peso, la única forma que se carguen las 3 al mismo tiempo, tendrían que pesar lo mismo.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 05/10/2008, 20:33
 
Fecha de Ingreso: marzo-2008
Mensajes: 37
Antigüedad: 9 años, 8 meses
Puntos: 0
Respuesta: Problema SWF y FLA

Bandit,

las 3 pelis pesan lo mismo pero no se cargan como deberían, no hay otro método quizas con AS para que se carguen al mismo tiempo, la verdad soy nuevo en esto de flash y no se nada de AS pero debe haber forma de hacer en código lo que necesito.

Que muestre las pelis una vez que se cargaron las 3???
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:53.