Foros del Web » Creando para Internet » Flash y Actionscript »

problemas clip de pelicula

Estas en el tema de problemas clip de pelicula en el foro de Flash y Actionscript en Foros del Web. Hola a [email protected]: Tengo un problemilla con un clip de película, y haber si me podeis ayudar un poco, pq me esta volviendo loco... He ...
  #1 (permalink)  
Antiguo 06/04/2007, 08:03
 
Fecha de Ingreso: abril-2007
Mensajes: 8
Antigüedad: 10 años, 8 meses
Puntos: 0
problemas clip de pelicula

Hola a [email protected]:

Tengo un problemilla con un clip de película, y haber si me podeis ayudar un poco, pq me esta volviendo loco...

He echo un clip de pelicula, para animar un fotograma de la primera escena,
quiero que cuando acabe de reproducirse aparezca un boton para saltar a la escena 2, pero el problema es que me vuelve a reproducir dicho clip...
inserto el boton en el ultimo fotograma del clip, le doy la etiqueta de goto>escena 2, y nada ...Lo estoy haciendo bien?
  #2 (permalink)  
Antiguo 06/04/2007, 08:35
 
Fecha de Ingreso: septiembre-2006
Mensajes: 328
Antigüedad: 11 años, 3 meses
Puntos: 3
Re: problemas clip de pelicula

En el fotograma donde quieres que se detenga la pelicula (para que no se vuelva a repetir) pon :

stop ();
  #3 (permalink)  
Antiguo 06/04/2007, 10:05
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: problemas clip de pelicula

Hola lcp881:
Bienvenido al Foro.
Primero tienes que poner una etiqueta en el primer frame de la escena donde quieres ir, por ejemplo: inicio.
En el último frame del MC coloca un stop() y en el botón el siguiente código:
on(release){
_root.gotoAndPlay("inicio");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 06/04/2007, 10:35
 
Fecha de Ingreso: abril-2007
Mensajes: 8
Antigüedad: 10 años, 8 meses
Puntos: 0
Re: problemas clip de pelicula

muchas gracias por tu ayuda...

problema solucionado, pero pq on(release){
_root.gotoAndPlay("2",1);
}

que es el root.???
  #5 (permalink)  
Antiguo 06/04/2007, 11:59
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: problemas clip de pelicula

Simple, porque el botón está dentro del MC y la escena está en la línea de tiempo principal. Por lo tanto debemos decirle en el botón que vaya a la escena que está en el _root o línea de tiempo principal
Y no necesitas colocar el código así: _root.gotoAndPlay("2",1); el 1 está demás, solamente debe ser así: _root.gotoAndPlay("2"); si la etiqueta que haz puesto en el primer frame de la escena es 2.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:49.