Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con accion sencilla

Estas en el tema de Problemas con accion sencilla en el foro de Flash y Actionscript en Foros del Web. Tengo en _root un clip llamado c_bola (ya esta puesto tambien el mismo nombre de instancia), y en el mismo fotograma pongo esta acción: _root.c_bola.onEnterFrame=function(){ ...
  #1 (permalink)  
Antiguo 26/12/2005, 20:40
 
Fecha de Ingreso: abril-2005
Ubicación: Barcelona
Mensajes: 101
Antigüedad: 12 años, 7 meses
Puntos: 0
Problemas con accion sencilla

Tengo en _root un clip llamado c_bola (ya esta puesto tambien el mismo nombre de instancia), y en el mismo fotograma pongo esta acción:

_root.c_bola.onEnterFrame=function(){
xvel=1
yvel=1
this._x+=xvel
this._y+=yvel}

Me va sin problemas, el caso es que al intentar que la velocidad acelera con esta otra acción no me va:

_root.c_bola.onEnterFrame=function(){
xvel+=1
yvel+=1
this._x+=xvel
this._y+=yvel}

a ver si alguien m puede decir qué pasa....thanks
  #2 (permalink)  
Antiguo 27/12/2005, 09:48
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola luis_cuvi:
para que la animación sea más rápida solamente cambia el valor, por ejemplo a 3 de estás líneas:
xvel=1
yvel=1


El código quedaría así:
_root.c_bola.onEnterFrame=function(){
xvel=3;
yvel=3;
this._x+=xvel
this._y+=yvel
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:58.