Foros del Web » Creando para Internet » Flash y Actionscript »

problemas con archivos externos

Estas en el tema de problemas con archivos externos en el foro de Flash y Actionscript en Foros del Web. hola! mmm no sé si ya se haya tratado un tema similar, si conocen el link, ps pásenlo por favor :) ...bueno mi problema es ...
  #1 (permalink)  
Antiguo 22/12/2009, 11:07
 
Fecha de Ingreso: diciembre-2009
Mensajes: 4
Antigüedad: 10 años, 11 meses
Puntos: 0
problemas con archivos externos

hola! mmm no sé si ya se haya tratado un tema similar, si conocen el link, ps pásenlo por favor :)

...bueno mi problema es que hice una página en flash, donde cada sección es un .swf externo, que a su vez carga archivos externos .jpg

(entonces la estructura queda +- asi:
home.swf > productos.swf)

entonces lo .jpg se cargan bien en productos.swf
pero ya no se ven cuando se entra desde el home.swf

alguien sabe cual puede ser el problemilla por el que no carguen los .jpg??

de antemano gracias / uso actionscript2
  #2 (permalink)  
Antiguo 22/12/2009, 11:39
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 17 años, 4 meses
Puntos: 406
Respuesta: problemas con archivos externos

Hola raider33:
Bienvenido al Foro.
Posiblemente en los códigos de los .swf externos estás apuntando al _root, por eso no te funciona al cargarlo desde la principal, lo que tienes que hacer es en el primer frame de tu película externa colocar éste código: this._lockroot = true;

Espero haberte sido de ayuda y ¡¡¡Feliz Navidad!!!
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 22/12/2009, 13:51
 
Fecha de Ingreso: diciembre-2009
Mensajes: 4
Antigüedad: 10 años, 11 meses
Puntos: 0
Respuesta: problemas con archivos externos

hola, gracias por responder, usaré el tip la próxima vez...
sucede que lo que tenia que hacer era escribir tooooda la ruta, para que las reconociera el archivo de home (que es el que esta tomando los demas swf)

es decir, la ruta del .swf que esta tomando el .jpg deberia quedar: swf/productos/thumbs/producto1.jpg (es escribir la ruta como si fuera home el que esta tomando el .jpg)
cuando sólo la tenía: thumbs/producto1.jpg

mmm no sé si ésto pueda ejemplificar bien lo que estaba haciendo. por si tienen problemas parecidos, ya saben cual puede ser la solución... saludos y gracias!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:46.