Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con botones en AS3

Estas en el tema de Problemas con botones en AS3 en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un pequeño problemita que no logro solucionar. A ver si alguien se ha topado con esto y sabe como hacerlo. Tengo unos botones ...
  #1 (permalink)  
Antiguo 08/02/2009, 21:02
Avatar de Gustavo72  
Fecha de Ingreso: abril-2008
Ubicación: -32.956045,-60.661355
Mensajes: 195
Antigüedad: 9 años, 8 meses
Puntos: 9
Problemas con botones en AS3

Hola, tengo un pequeño problemita que no logro solucionar.
A ver si alguien se ha topado con esto y sabe como hacerlo.

Tengo unos botones en Flash. En AS3 detecto el click sobre los mismos y ejecuto una función:

Código:
function gotoPage(destino:String):void {
	navigateToURL(new URLRequest(destino), "_self");
}
boton.addEventListener(MouseEvent.CLICK, function(){gotoPage("mi-url.html")});
Mientras utilizo símbolos gráficos dentro del botón todo parece funcionar bien. El problema surge cuando meto clips de películas. Me tira el siguiente error:

TypeError: Error #1009: No se puede acceder a una propiedad o a un método de una referencia a un objeto nulo.


y no funciona.
Si alguien sabe como solucionarlo espero respuestas.
Saludos.

Gustavo

Última edición por Gustavo72; 08/02/2009 a las 22:48
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:53.