Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con los botones de mi web..help

Estas en el tema de Problemas con los botones de mi web..help en el foro de Flash y Actionscript en Foros del Web. Tengo una web que consta de varios botones que estos cargan a su vez peliculas externas, mi problema es que cuando le hago un click ...
  #1 (permalink)  
Antiguo 29/01/2007, 07:53
 
Fecha de Ingreso: mayo-2005
Mensajes: 2
Antigüedad: 12 años, 6 meses
Puntos: 0
Problemas con los botones de mi web..help

Tengo una web que consta de varios botones que estos cargan a su vez peliculas externas, mi problema es que cuando le hago un click funciona correctamente, pero todavia hay gente que hace doble click y aqui es cuando empieza mi problema. Una vez que hago doble, empieza a hacer como un mc sin stop, empieza a flipear y cuando uno empieza a flipear, todas las peliculas hacen lo mismo, aunque le haga un solo click. He descubierto este error y me pasa en todas las paginas, por favor una ayuda de cualquier tipo.
Desde ya muchas gracias a todos los que puedan hacer un aporte.
  #2 (permalink)  
Antiguo 29/01/2007, 09:04
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: Problemas con los botones de mi web..help

Hola pablomar23:
Bienvenido al Foro.
El problema que en algunos tienen que hacer doble clic es porque deben tener actualizado en IE a la versión 7, y los que solamente hacen un sólo clic es porque tiene la versión 6.
Para corregir ese problema, busca en éste mismo Foro la respuesta.
Para saber lo que pasa con el bucle que realiza tus animaciones lo mejor sería ver tu archivo. fla.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 31/01/2007, 09:09
 
Fecha de Ingreso: mayo-2005
Mensajes: 2
Antigüedad: 12 años, 6 meses
Puntos: 0
Re: Problemas con los botones de mi web..help

La pelicula no tiene ninguna complicacion, tiene un load movie y nada mas, cada pelicula cuenta con su cargador y un stop al final. Es muy primario, pero aun asi me ocasiona problemas. Como puedo anular el boton una vez que ya esta accionado?? La botonera esta dentro de un mc. mi web tersoglio com ar. muchas gracias.
  #4 (permalink)  
Antiguo 31/01/2007, 09:16
Avatar de PabloSutra  
Fecha de Ingreso: octubre-2006
Ubicación: Guadalajara, México
Mensajes: 222
Antigüedad: 11 años, 2 meses
Puntos: 0
Re: Problemas con los botones de mi web..help

hola pablomar23:
lo que se me ocurre es con un if por ejemplo, se me ocurre es que pongas en el codigo en el frame:
Cita:
var activo:Boolean;
activo=true;
y en el codigo del boton:
Cita:
on (release) {
if (activo) {
activo = false;
loadMovie("tupelicula.swf");
} else {
activo = true;
}
}
Espero te sirva, esto es algo valgo no lo he intentado pero me imagino que funcionará.
Espero te funcione
SALUD!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:08.