Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con enlaces IE7

Estas en el tema de Problemas con enlaces IE7 en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un rpoblema en el trabajo y no sé como solucionarlo. La cuestión es que he realizado varios banners para el portal de la ...
  #1 (permalink)  
Antiguo 09/02/2010, 07:11
 
Fecha de Ingreso: agosto-2009
Mensajes: 35
Antigüedad: 11 años, 7 meses
Puntos: 0
Problemas con enlaces IE7

Hola, tengo un rpoblema en el trabajo y no sé como solucionarlo. La cuestión es que he realizado varios banners para el portal de la empresa. Dos de ellos están en as2 y otro en as3. En principio estos funcionaban perfectamente y a mi los enlaces de dichos banners no me daban problemas. El problema ha llegado cuando esta mañana mi jefa me ha dicho que el enlace de los banners en as2 no funciona.

Tras investigar poco descubrí que a mi si me funcionaban y a ella no porque yo utilizo firefox y IE 8 mientras que ella utiliza IE7. La cuestión es que son banner incorporados mediante php por lo que aparecen en varias páginas. La cosa es que cuando ella hacía clic en el de as3 que si le funcionaba al abrir la nueva ventan, en ésta ya le funcionaban los enlaces de todos los banners mientras que en la ventana original sólo le funcionaba el de as3.

Lo crioso llega cuando me dice que tengo que cambiar el hecho en as3 para que se abra en la misma ventana. Al hacerlo ya no le funciona ningún enlace. No sé que hacer para solucionarlo. He probado hasta exportarlos en Flash Player 6 (sólo los de AS2, claro) pero le siguen sin funcionar. Se le ven pero el enlace no va(repito que en IE 7, en mi IE8 sí).

Una ayudita, por favor.

Por cierto, es posible que estos banners no se vean en IE6 aunk tengan instalado el flash player 10? Mis jefes sólo utilizan el IE6 y no los ven.


A continuación os dejo los "complicadisimos" codigos utilizados:

Código AS2 en el botón de los banners 1 y 2

Código:
on(release){
	getURL("http://www.direcciondelaempresa.com");
}
Código AS3 en el banner 3

Código:
function ir_a(e:MouseEvent):void{
	navigateToURL(new URLRequest("http://www.direcciondelaempresa.com"),"_self");
}
stage.addEventListener(MouseEvent.CLICK, ir_a);
  #2 (permalink)  
Antiguo 09/02/2010, 07:38
Avatar de Jime25  
Fecha de Ingreso: septiembre-2009
Ubicación: Mi casa
Mensajes: 1.213
Antigüedad: 11 años, 7 meses
Puntos: 138
Respuesta: Problemas con enlaces IE7

Hola,
en el código as2 falta el _self o el _blank para que abra en la misma página o en otra ventana.
Los banners ya están subidos a Internet?? Yo tenía un problema con enlaces de actionscript 2 antes de subirla, pero después de subida ya funcionaba todo bien.
Saludos
__________________
Jime~

Mi blog.
Mi twitter.
  #3 (permalink)  
Antiguo 09/02/2010, 10:43
 
Fecha de Ingreso: agosto-2009
Mensajes: 35
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: Problemas con enlaces IE7

Lo sé, pero ese no es el problema, si utilizo el _self no me van, en cambio si utilizo _blank en IE7 si van. No tiene lógica alguna.


Sí, ya están subidos a Internet

Etiquetas: enlaces
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:01.