Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con LoadMovie

Estas en el tema de Problemas con LoadMovie en el foro de Flash y Actionscript en Foros del Web. Amigos estoy por aki despues de mucho tiempo tengo un poblemilla y Uds. siempre me han sabido bien ayudar Tengo en mi libreria un Mc ...
  #1 (permalink)  
Antiguo 20/06/2008, 18:02
Avatar de Cyberlobito
Usuario no validado
 
Fecha de Ingreso: junio-2004
Ubicación: Lima, Perú
Mensajes: 145
Antigüedad: 13 años, 5 meses
Puntos: 0
De acuerdo Problemas con LoadMovie

Amigos estoy por aki despues de mucho tiempo tengo un poblemilla y Uds. siempre me han sabido bien ayudar

Tengo en mi libreria un Mc llamado wsprite y le puse de linkage para AS el mismo nombre

el cual atacho a mi escena de la siguiente manera

attachMovie("wsprite","boton",190)

hasta ahi todo bien
ahora kiero ke este cuadradito me sirva de boton con el siguiente codigo

boton.onRelease = function() {
trace("has presionado el boton")
};

igual hasta ahi vamos todo bien

Sin embargo cuando kiero usar ese wsprite como contenedor y le agrego un contenido externo ya no me funciona como boton lo hago con este codigo>

loadMovie("accesorios/foto4.swf","botonazo")


Fianlmente mi codigo keda de la siguiente manera:

//atacho un Mc desde la biblioteca
attachMovie("wsprite","boton",190)
//le cargo una imagen usando boton como contenedor
loadMovie("accesorios/foto4.swf","botonazo")
//le doy comportamiento de boton
boton.onRelease = function() {
trace("holas")
};

Nota: si no hiciera el loadMovie si funciona el boton

ESpero me puedan ayudar GRACIAS
  #2 (permalink)  
Antiguo 20/06/2008, 18:43
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problemas con LoadMovie

Hola Cyberlobito:
Si el MC al ser attachado toma el nombre de: boton, el código sería así:
attachMovie("wsprite","boton",190)
boton.onRelease = function() {
boton.loadMovie("accesorios/foto4.swf");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 20/06/2008, 18:56
Avatar de Cyberlobito
Usuario no validado
 
Fecha de Ingreso: junio-2004
Ubicación: Lima, Perú
Mensajes: 145
Antigüedad: 13 años, 5 meses
Puntos: 0
Respuesta: Problemas con LoadMovie

amigo me ekivoke en escribirlo pero no me has entendido el asunto es el siguiente

kiero ke el MC ke sera el boton tenga contenido un swf y cuando lo precione hara otra cosa

//atacho un Mc desde la biblioteca
attachMovie("wsprite","boton",190)

//le cargo una imagen usando boton como contenedor
loadMovie("accesorios/foto4.swf","boton")

//le doy comportamiento de boton
boton.onRelease = function() {
trace("holas")
};

osea mi boton es un contenedor de un swf y ke al apretarlo haga el trace por ejemplo
  #4 (permalink)  
Antiguo 20/06/2008, 18:57
Avatar de Cyberlobito
Usuario no validado
 
Fecha de Ingreso: junio-2004
Ubicación: Lima, Perú
Mensajes: 145
Antigüedad: 13 años, 5 meses
Puntos: 0
Respuesta: Problemas con LoadMovie

solo para añadir algo mas antes de hacer el loadMovie el boton si funciona pero cuando lo uso de contenedor no funciona el boton espero me entiendan gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:34.