Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con loadMovie

Estas en el tema de Problemas con loadMovie en el foro de Flash y Actionscript en Foros del Web. Hola de nuevo!! Tengo un gran problema con loadMovie, espero me puedan ayudar y es: Tengo toda la interfaz de mi web, uno de los ...
  #1 (permalink)  
Antiguo 08/09/2008, 21:49
 
Fecha de Ingreso: agosto-2008
Mensajes: 25
Antigüedad: 9 años, 3 meses
Puntos: 0
Problemas con loadMovie

Hola de nuevo!!
Tengo un gran problema con loadMovie, espero me puedan ayudar y es:
Tengo toda la interfaz de mi web, uno de los botones quiero que vaya a un frame específico y cargue la película externa.
Ya tengo mi MC vacío en el frame que quiero, y el siguiente código en las acciones de su botón:
on (release) {
_parent.loadMovieNum("portafolio.swf", 60);
this.contenedor_mc.loadMovieNum("portafolio.swf", 60);
}

El problema es que no carga la película, necesito ayuda urgente!!!
Gracias!!
  #2 (permalink)  
Antiguo 09/09/2008, 06:31
 
Fecha de Ingreso: julio-2008
Mensajes: 74
Antigüedad: 9 años, 5 meses
Puntos: 1
Respuesta: Problemas con loadMovie

hola, prueba con el codigo siguiente:

on (release) {
_root.contenedor_mc.loadMovieNum("portafolio.swf", 60);
}

aunque te recomiendo que empieces a poner el codigo en las lineas de tiempo es decir que utilices codigos callbacks , así:

mi_boton.onRelease=function(){
_root.contenedor_mc.loadMovieNum("portafolio.swf", 60);
}

un saludo
  #3 (permalink)  
Antiguo 09/09/2008, 10:42
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problemas con loadMovie

Hola lila-skrlatta:
Si por ejemplo quieres ir al frame 20 y allí se cargue una película, tendrás que poner en ese frame el MC_vacío: contenedor y el siguiente código en ese frame: contenedor.loadMovie("portafolio.swf");

En el botón:
on(release){
gotoAndStop(20);
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #4 (permalink)  
Antiguo 09/09/2008, 18:01
 
Fecha de Ingreso: agosto-2008
Mensajes: 25
Antigüedad: 9 años, 3 meses
Puntos: 0
Problemas con loadMovie

Hola Gracias a los dos!!!
Que creen intenté con los códigos, de ustedes dos, pero en los dos aparece un mensaje de error, cuando hago test movie y dice lo siguiente:

Wrong number of parameters; loadMovie requires between 2 and 3.
loadMovie("portafolio.swf");

Total ActionScript Errors: 1 Reported Errors: 1

Lo escribí tal cual ustedes me lo dieron y de hecho si en el .fla, dice que no hay errores en el código, pero cuando ya la veo no carga y tampoco me lleva al frame que quiero, que hago!!!! estoy desesperada!!!
Gracias!!
  #5 (permalink)  
Antiguo 09/09/2008, 18:09
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Problemas con loadMovie

Lo que pasa es que no has escrito el código como te lo di, por eso es el error.
Si te fijas bien en mi post anterior, el codigo está así: contenedor.loadMovie("portafolio.swf");

Espero habere sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:49.