Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con menu flash y xml!!!

Estas en el tema de Problemas con menu flash y xml!!! en el foro de Flash y Actionscript en Foros del Web. Hola a todos: Estoy diseñando un menú el cual se genera a través de un xml, en realidad no tengo mucha experiencia en esto así ...
  #1 (permalink)  
Antiguo 26/06/2007, 10:07
 
Fecha de Ingreso: junio-2007
Mensajes: 19
Antigüedad: 10 años, 5 meses
Puntos: 0
Pregunta Problemas con menu flash y xml!!!

Hola a todos:

Estoy diseñando un menú el cual se genera a través de un xml, en realidad no tengo mucha experiencia en esto así que agradecería que le dieran una checadita por que no hace exáctamente lo que quiero:

Explicaré rápidamente, tengo el siguiente xml:
<?xml version="1.0" encoding="utf-8"?>

<menuis name="Atlixco">
<menu name="Servicios Turisticos" link="">
<item name="Hoteles" link=""/>
<item name="Restaurantes" link=""></item>
<item name="Balnearios" link=""></item>
<item name="Cafeterias y discoteq" link=""></item>
<item name="Viveros" link=""></item>
<item name="Salones de Eventos" link="seccion1/salones.html"></item>
<item name="Agencias de Viaje" link="seccion1/agencias.html"></item>
<item name="Tour Operadores" link=""></item>
<item name="Ecoturismo" link="seccion1/ecoturismo.html"></item>
<item name="Museos, Pinacoteca y Murales" link="">
<items name="PENSAMIENTO Y ACCION LIBERAL" >Salon de cabildos</items>
<items name="LA HISTORIA DE ATLIXCO">Pasillo de palacio municipal</items>
<items name="LA EDUCACION EN LA HISTORIA DE ATLIXCO">Archivo fotográfico Municipal</items>
<items name="MOVIMIENTO OBRERO">Patio de Palacio Municipal</items>
<items name="HUEY ATLIXCAYOTL">Casa de la Cultura de Atlixco</items>
</item>
<item name="Diversión Extrema" link="seccion1/diversion.html"/>
</menu>
.... etc.

ahora en la parte de item y de menu hay un atributo llamado link el cual quiero leerlo para que me genere en el menú el link a esa sección y sea desplegada en un frame principal.

El problema con esto es que tengo ya parte del código pero no encuentro la forma de que me lea todos los link y aún no se como generar la función que me lea el atributo link y al dar click al título del menú me lleve a esa sección.

El código en flash que tengo hasta ahorita es el siguiente:
stop();
System.useCodepage = true;
_root.subs._visible = 0;
_root.backs._visible =0;

ruta = _root;
var M = new XML();
M.ignoreWhite = true;
M.onLoad = function(success){
if(success){
// CONTENEDOR DEL MENU-----------------------------------
ruta.attachMovie("submenu","menus",9876543210);
ruta["menus"]._x = 30.6;
ruta["menus"]._y = 266.0;
// CONTENIDO DEL MENU .....................
var mens = M.firstChild.childNodes;
for(a=0;a<mens.length;a++){
pathmenu = ruta.menus;
pathmenu.attachMovie("menu","mm_"+(a+1),a*10);
pathmenu.attachMovie("axion","ax_"+(a+1),a+155);
pathmenu["mm_"+(a+1)].nombre = mens[a].attributes.name;
pathmenu["ax_"+(a+1)].nombre = mens[a].attributes.name;
pathmenu["ax_"+(a+1)].link = mens[a].attributes.link;
pathmenu["ax_"+(a+1)].parent = mens[a].childNodes;
trace(pathmenu["ax_"+(a+1)].link);
pathmenu["mm_"+(a+1)]._x = 25;
pathmenu["mm_"+(a+1)]._y = pathmenu["mm_"+(a+1)]._height * a;
pathmenu["ax_"+(a+1)]._x = 25;
pathmenu["ax_"+(a+1)]._y = pathmenu["mm_"+(a+1)]._height * a;
}
}
else trace("no files");

};
M.load ("atlixco.xml");

con el trace verifiqué que la variable link solo contiene los valores de los link principales pero no de los submenús.

Espero que me haya dado a entender!!! Necesito ayuda pronto, gracias!!!
  #2 (permalink)  
Antiguo 26/06/2007, 15:55
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: Problemas con menu flash y xml!!!

estaba viendo tu codigo y creo que el problema esta en el XML, mejor lee esto

http://www.cristalab.com/tutoriales/...e-xml-en-flash
  #3 (permalink)  
Antiguo 26/06/2007, 18:26
 
Fecha de Ingreso: junio-2007
Mensajes: 19
Antigüedad: 10 años, 5 meses
Puntos: 0
De acuerdo Re: Problemas con menu flash y xml!!!

Gracias, ya logré solucionarlo!!!

ahora tengo otra duda.

Si tengo un getURL("http:.... "," _blank"); dentro de mi flash para hacer los links y ese flash está dentro de un frame llamado menu.html

Mi pregunta es: ¿si tengo un frame llamado "mainframe" cómo puedo direccionar o cambiar el _blank para que me lo direccione en mainframe?, obviamente ya puse "mainframe" que es el id correspondiente a dónde quiero colocarlo, pero no hace nada...

Es por que el flash está en un frame diferente?? Qué puedo cambiarle para que me lo muestre ahí???

Gracias!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:37.