Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con un reproductor mp3

Estas en el tema de Problemas con un reproductor mp3 en el foro de Flash y Actionscript en Foros del Web. Hola chicos, Tengo un problemita con un reproductor mp3 que estoy haciendo.. el caso es que en local solo al entrar se reproduce automaticamente, pero ...
  #1 (permalink)  
Antiguo 12/08/2006, 06:41
 
Fecha de Ingreso: agosto-2006
Mensajes: 81
Antigüedad: 11 años, 4 meses
Puntos: 0
Problemas con un reproductor mp3

Hola chicos,
Tengo un problemita con un reproductor mp3 que estoy haciendo.. el caso es que en local solo al entrar se reproduce automaticamente, pero al subirlo a internet hay que darle al boton de play. No entiendo pk pasa..

En el primer fotograma he puesto el siguiente script

mireproductor= new Sound()
mireproductor.loadSound("mp3/sonido.mp3",false)
function comenzar(){
mireproductor.start(0,1000)
}
mireproductor.onLoad = comenzar()
stop();

tb hay programación en los botones de play y stop pero considero que estos ya funcionan correctamente

Alguien me puede ayudar?????
  #2 (permalink)  
Antiguo 12/08/2006, 10:28
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola seresac:
Bienvenido al Foro.
Con el código que tienes allí no va iniciarce el sonido a menos que presiones un botón, porque lo tienes en false y solamente va a sonar una sola vez.
El código escrínelo así:
mireproductor = new Sound();
mireproductor.loadSound("mp3/sonido.mp3", true);
mireproductor.onSoundComplete = function(){
mireproductor.start(0, 1);
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 13/08/2006, 10:46
 
Fecha de Ingreso: agosto-2006
Mensajes: 81
Antigüedad: 11 años, 4 meses
Puntos: 0
Hola bandit,
gracias por tu rapida respuesta, he probado lo que me dices pero la musica empieza a sonar automaticamente, pero se crea una especie de blucle y la melodia empieza multiples veces una encima de otra... que raro no?
  #4 (permalink)  
Antiguo 13/08/2006, 11:18
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Se suponía que querías que el sonido empiece a sonar ni bien ingresas a la página, al menos eso entendí en tu pregunta, por eso te di el código, si va hacer un bucle, pero cuando termine recién volverá a sonar el mismo sonido, el cual lo puedes parar o reiniciar con tus botones que tienes allí.
Si está sonando múltiples veces, es porque posiblemente estás presionando el botón Play al estar escuchándose el sonido.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 13/08/2006, 13:40
 
Fecha de Ingreso: agosto-2006
Mensajes: 81
Antigüedad: 11 años, 4 meses
Puntos: 0
Hola Bandit,
Cierto repeti rehice de nuevo el reproductor en un nuevo archivo fla y ahora si funcionó. Nose al igual el archivo estaba dañado o algo así? en defenitiva que muchas gracias por tu ayuda :)

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:27.