Foros del Web » Creando para Internet » Flash y Actionscript »

problemas con scrollpanel

Estas en el tema de problemas con scrollpanel en el foro de Flash y Actionscript en Foros del Web. Hola! tengo una pelicula flash en la que en un scrollpanel se tendría que cargar un simbolo de la biblioteca, un simbolo grafico. Pues bien, ...
  #1 (permalink)  
Antiguo 19/06/2006, 06:38
 
Fecha de Ingreso: enero-2006
Mensajes: 143
Antigüedad: 11 años, 11 meses
Puntos: 0
problemas con scrollpanel

Hola!

tengo una pelicula flash en la que en un scrollpanel se tendría que cargar un simbolo de la biblioteca, un simbolo grafico. Pues bien, pese a poner el simbolo exportado en primer frame, no se carga el componente, es decir, el scrollpanel no aparece.

no me preocuparía si al menos apareciera el scrollpanel vacío, pero el caso es que ni aparece el scrollpanel.

Sabeis a qué es debido?
  #2 (permalink)  
Antiguo 19/06/2006, 11:13
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Garto-la:
Supongamos que tenemos el scrollPane en el escenario y al símbolo lo Vinculamos con el nombre de foto, seleccionamos el componente y en el panel de propiedades allí donde dice: contentPath escribimos el nombre que dimos al vincularlo o sea en éste caso foto.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 20/06/2006, 11:51
 
Fecha de Ingreso: enero-2006
Mensajes: 143
Antigüedad: 11 años, 11 meses
Puntos: 0
Bandit, siempre es de ayuda tu punto de vista... Gracias.

Sigo con el problema, de hecho, solo conozco una manera de vincular el símbolo al componente, qué, como dices, es en el contentpath... Pongo el nombre del símbolo (por ej. foto) pero igualmente me pasa lo que explico más arriba. A ver si se te ocurre algo a ti, pq yo he agotado mis ideas... No será por temas de exportar en primer fotograma ni nada así?
  #4 (permalink)  
Antiguo 21/06/2006, 05:38
 
Fecha de Ingreso: enero-2006
Mensajes: 143
Antigüedad: 11 años, 11 meses
Puntos: 0
por cierto, una anotación, por si te orienta un poco más sobre el error que obtengo:

si vinculo al scrollpanel un símbolo inexistente, por lo menos se ve el recuadro del componente vacío, pero si vinculo el símbolo que tiene que mostrar, no sale ni el cuadro de componente.
  #5 (permalink)  
Antiguo 21/06/2006, 11:30
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Garto-la:
Vincular no es solamente colocar el nombre en las propiedades del componente, es clicar con el dercho sobre el nombre del MC que está en la biblioteca y en la ventanaque aparece darle a Vinculación, en la siguiente ventana ponerle un nombre, como para el ejemplo foto. activar donde dice: Exportar para ActionScript y Aceptar.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:56.