Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con el sonido

Estas en el tema de Problemas con el sonido en el foro de Flash y Actionscript en Foros del Web. Hola que tal, en un proyecto flash hice un reproductor de sonido algo simple, boton play y stop sube y baja de volumen, el reproductor ...
  #1 (permalink)  
Antiguo 07/12/2009, 10:17
 
Fecha de Ingreso: noviembre-2008
Mensajes: 121
Antigüedad: 12 años, 3 meses
Puntos: 9
Problemas con el sonido

Hola que tal, en un proyecto flash hice un reproductor de sonido algo simple, boton play y stop sube y baja de volumen, el reproductor carga el sonido desde la bibloteca, no exteriormente, funciona bien, lo probe con html y lo subi a un servidor y funciona correctamente, el problema es que este reproductor que esta en swf lo intente acoplar a otro proyecto de flash de forma externa con loadMovie en un MC vacio, el swf carga en el MC vacio bien y funciona todo lo del reproductor pero no sale el sonido y no entiendo por que, es como si desconociera la musica del reproductor, pero cuando abro el reproductor solito funciona bien, como podria solucionarlo o cual es mi problema, de ante mano gracias.
  #2 (permalink)  
Antiguo 07/12/2009, 10:30
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 17 años, 7 meses
Puntos: 406
Respuesta: Problemas con el sonido

Hola AnddyCero:
En el primer frame de la película que contiene el sonido escribe éste código: this._lockroot = true;

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/

Última edición por Bandit; 08/12/2009 a las 17:30
  #3 (permalink)  
Antiguo 07/12/2009, 23:57
 
Fecha de Ingreso: noviembre-2008
Mensajes: 121
Antigüedad: 12 años, 3 meses
Puntos: 9
Respuesta: Problemas con el sonido

Hola bandit que tal, creo que te equivocaste en el script "this._lockriit = true;" seria: this._lockroot = true; bueno si ya lo habia puesto ese script mas antes, pero igual no funciona el sonido se queda en completo silencio no se que puede ser.
  #4 (permalink)  
Antiguo 08/12/2009, 17:35
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 17 años, 7 meses
Puntos: 406
Respuesta: Problemas con el sonido

Efectivamente fue un error al escribir el código, ya fue corregido.
Porque no subes tus archivos algún servidor para poderlo bajar y ver cual es el problema.

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 09/12/2009, 12:52
 
Fecha de Ingreso: noviembre-2008
Mensajes: 121
Antigüedad: 12 años, 3 meses
Puntos: 9
Respuesta: Problemas con el sonido

Ok Bandit gracias por la ayuda prestada otra ves, ok los colgare apenas llegue a mi casa si no tengo otro contratiempo por el camino XD, un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:43.