Foros del Web » Creando para Internet » Flash y Actionscript »

problemas al llamar funcion con parametros

Estas en el tema de problemas al llamar funcion con parametros en el foro de Flash y Actionscript en Foros del Web. Hola a todos tengo un problema al llamar funciones en action script de esta manera ejecuto funciones en el evento press de un boton: opc4.onPress ...
  #1 (permalink)  
Antiguo 14/03/2007, 09:54
Avatar de jair20x  
Fecha de Ingreso: noviembre-2005
Ubicación: Madrid - España
Mensajes: 531
Antigüedad: 12 años
Puntos: 1
Exclamación problemas al llamar funcion con parametros

Hola a todos tengo un problema al llamar funciones en action script

de esta manera ejecuto funciones en el evento press de un boton:
opc4.onPress = _root.ejecutar4;

hasta no hay problemas

pero si quiero pasar parametros:
opc4.onPress = _root.ejecutar4("1");

aca comienza los problemas ya que la funcion se ejecuta sin antes haber
presionado el boton y cuando presione el boton no llama a la funcion

alguien sabe cual es la manera correcta de hacerlo???
Saludos
  #2 (permalink)  
Antiguo 15/03/2007, 17:35
Avatar de sheshu  
Fecha de Ingreso: abril-2006
Ubicación: En too el medio
Mensajes: 160
Antigüedad: 11 años, 8 meses
Puntos: 0
Re: problemas al llamar funcion con parametros

hola,

te funcionará de este modo:
Código:
opc4.onPress = function(){
  _root.ejecutar4("1");
}
un saludo,

sheshu
__________________
sheshu ::: www.tutoriales-flash.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:22.