Foros del Web » Creando para Internet » Flash y Actionscript »

problemas al registrar usuarios

Estas en el tema de problemas al registrar usuarios en el foro de Flash y Actionscript en Foros del Web. hola amigos como estan? tengo un problema, espero que alguien me pueda ayudar, en la web encontre un codigo de flash que trabaja con php ...
  #1 (permalink)  
Antiguo 29/04/2008, 16:24
 
Fecha de Ingreso: abril-2008
Mensajes: 13
Antigüedad: 9 años, 8 meses
Puntos: 0
problemas al registrar usuarios

hola amigos como estan?
tengo un problema, espero que alguien me pueda ayudar, en la web encontre un codigo de flash que trabaja con php y mysql para autenticar usuarios, cuando lo aplico en un flash nuevo funciona, pero cuando lo aplico en un flash que ya tiene una pelicula hecha con animaciones con las cajas de introduccion de texto entonces no me aparece nada de nada.... la pelicula termina en el frame 40, y es ahi donde ya estan listas las cajas de introduccion de texto y el boton aceptar.

en ese mismo frame 40 es donde pongo el siguiente codigo:
stop();
var envio:LoadVars = new LoadVars();
var recibir:LoadVars = new LoadVars();
function login() {
envio.username = username_txt.text;
envio.password = password_txt.text;
envio.action = "login";
envio.sendAndLoad("consulta.php", recibir, "POST");
}
recibir.onLoad = function(exito) {
if (exito) {
switch (this.opcion) {
case "0" :
mensaje_txt.text = "no existe el usuario";
break;
case "1" :
mensaje_txt.text = "nombre de usuario o pass mal ingresado";
break;
case "2" :
mensaje_txt.text = "datos correctos";
//acá pueden agregar acciones para los registrados
break;
default :
mensaje_txt.text = "no hay conexión";
break;
}
} else {
mensaje_txt.text = "Error en el Script";
}
};

y en el boton el codigo es el siguiente:
on (release){
login();
mensaje_txt.text = "conectando...";
}

porsupuesto que esta hecho el archivo php que me recibe los datos y otro archivo php para la coneccion a la bd.
como les conte, cuando aplico este codigo en un flash vacio, sin ninguna pelicula, funciona perfecto, cuando lo quiero aplicar en el flash que si tiene una pelicula, no hace nada de nada...

porfavor que alguien me ayude, gracias
  #2 (permalink)  
Antiguo 29/04/2008, 17:46
 
Fecha de Ingreso: febrero-2008
Mensajes: 30
Antigüedad: 9 años, 9 meses
Puntos: 0
Re: problemas al registrar usuarios

Men derrepente el error esta en los otros archivos si puedes postealos o mandamelos para verlos bien ok
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:35.