Foros del Web » Creando para Internet » Flash y Actionscript »

Problemilla con cargador....

Estas en el tema de Problemilla con cargador.... en el foro de Flash y Actionscript en Foros del Web. Mi problema es es siguirente. tengo una animacion de 14 escenas, el primer frame de la primera escena tengo el codigo para desabilitar el clik ...
  #1 (permalink)  
Antiguo 01/08/2005, 19:23
Avatar de pituu2  
Fecha de Ingreso: abril-2004
Ubicación: paraná entre rios
Mensajes: 274
Antigüedad: 13 años, 7 meses
Puntos: 0
Problemilla con cargador....

Mi problema es es siguirente.
tengo una animacion de 14 escenas, el primer frame de la primera escena tengo el codigo para desabilitar el clik derecho del mouse, un stop y el cargador, con este codigo:

onClipEvent (load) {
// total de bytes de la movie
b_total = _root.getBytesTotal();
}
onClipEvent (enterFrame) {
// bytes cargados
b_loaded = _root.getBytesLoaded();
// si ya se cargaron todos los bytes
if (b_loaded>=b_total) {
// play a la movie principal en el label inicio
_root.gotoAndPlay("holland");
// si no...
} else {
// sacamos el porcentaje
porcentaje = (b_loaded/b_total)*100;
// le aplicamos el porcentaje a la barra *ver nota
barra._xscale = porcentaje;
// genera el output en esta forma: 75% cargado
output = Math.floor(porcentaje)+"% cargado";
}
//
//
// -----
// nota:
// -----
// 1.el pocentaje da números de 0-100, por lo que al aplicarle el
// valor del porcentaje a la escala x de la barra va a dar la sensación
// de que está creciendo
//
// 2.Si el porcentaje es igual a (b_loaded/b_total)*100, y luego se lo
// aplicamos a la barra, nos podemos ahorrar un paso aplicándole el
// resultado de una vez .
//
// barra._xscale=(b_loaded/b_total)*100;
//
// lo puse en dos partes para que quedara más fácil de entender
//
}

Bueno en el frame 5 de la escena 1 carga el sonido de fondo con este codigo:

s = new Sound(tema1);
s.attachSound("tema1");
s.setVolume(1);
s.start(0, 999);
for (i=1; i<=50000; i++) {
s.setVolume(i/500);
}

Lo que pasa es que recien me muestra el cargador cuando va por el 18 %, y para que llegue al 18 % hay que esperar un ratito ya que tiene que cargar alrrededor de 390 Kb.
Y todo este tiempo queda la ventana que dicho sea de paso es un pop up, en blanco, cuando me tendria que mosrtar el cargador y el fondo que tiene la pagina.

espero haberme explicado bien.

gracias por todo y espero su respuesta.
__________________
pituu2
  #2 (permalink)  
Antiguo 01/08/2005, 20:39
Avatar de pituu2  
Fecha de Ingreso: abril-2004
Ubicación: paraná entre rios
Mensajes: 274
Antigüedad: 13 años, 7 meses
Puntos: 0
Es más creo que el problema está en el frame 5 porque voy a la libreria y le saco el linkage al sonido y el cargador empiesa bien, sera que el sonido está retrasando la cosa, pesa como 90 Kb.
__________________
pituu2
  #3 (permalink)  
Antiguo 03/08/2005, 10:39
Avatar de pituu2  
Fecha de Ingreso: abril-2004
Ubicación: paraná entre rios
Mensajes: 274
Antigüedad: 13 años, 7 meses
Puntos: 0
ya lo solucione, el problema estaba en que no puedo linkear el sonido de la libreria, esto asia que el cargador se atrasara, porque al likear el sonido tiene una opcion que creo si o si tiene que estar tildada, que dice que lo va a cargar en el primer frame, que es donde esta el cargador, entonces supongo que primero cargaba el sonido y despues te mostraba el cargador. CREEO.

igual ahora anda por lo menos, cuando suba la animacion les paso el link, haber que opinan.

igual gracias.
__________________
pituu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:35.