Foros del Web » Creando para Internet » Flash y Actionscript »

S.O.S. portfolio con swf aleatorios

Estas en el tema de S.O.S. portfolio con swf aleatorios en el foro de Flash y Actionscript en Foros del Web. Estoy haciendo un sitio que tiene un portfolio. En mi pelicula principal tengo un movieclip vacío y botones que cargan los distintos trabajos (swfs externos), ...
  #1 (permalink)  
Antiguo 12/08/2005, 07:10
 
Fecha de Ingreso: mayo-2002
Mensajes: 148
Antigüedad: 15 años, 6 meses
Puntos: 0
S.O.S. portfolio con swf aleatorios

Estoy haciendo un sitio que tiene un portfolio.
En mi pelicula principal tengo un movieclip vacío y botones que cargan los distintos trabajos (swfs externos), que funcionan O.K. (este es el código que tienen los botones)

on (release) {
gorda.loadMovie("gorda.swf");
}

on (release) {
gorda.loadMovie("cena.swf");
}

etc.

Necesito que cuando se abre la página, en lugar de quedar el area de trabajos vacía, que se carguen trabajos aleatoriamente.

Para esto hice un swf con un movieclip vacío y en el layer del movieclip puse este código (que funciona O.K.)

loadMovie("ima00"+random(5)+".swf", ima00_mc);
numero = random(3);
if(numero==0){
loadMovieNum("ima001.swf", 0);
}else{
if(numero==1){
loadMovieNum("ima002.swf", 0);
}else{
if(numero==2){
loadMovieNum("ima003.swf", 0);
}
}
}

En mi película principal puse una capa nueva y un movieclip vacío que llame al swf aleatorio, y entonces solo se ejecuta este swf y no carga nada del resto de la película .
También probé a poner directo el movieclip del swf aleatorio en la peli principal, pero sucede lo mismo.
Incluso probé a poner una capa dentro del movieclip vacío donde se ejecutan los swfs que llamo con los botones y pasa lo mismo.

Ayuda, ya no sé que probar
  #2 (permalink)  
Antiguo 12/08/2005, 07:15
 
Fecha de Ingreso: diciembre-2004
Ubicación: La Rioja
Mensajes: 336
Antigüedad: 13 años
Puntos: 2
Hola vale, creo que es un problema de niveles.

Si cargas algo en el nivel 0 haces que desaparezca la película principal. Empieza a cargar a partir del nivel 1 y deja siempre el 0 intacto.

Ya me dirás si era eso
  #3 (permalink)  
Antiguo 12/08/2005, 07:54
 
Fecha de Ingreso: mayo-2002
Mensajes: 148
Antigüedad: 15 años, 6 meses
Puntos: 0
Si, si, si!!!

Estabas en lo cierto,
1.000.000 de gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:30.