Foros del Web » Creando para Internet » Flash y Actionscript »

script maldito (lentifica el reproductor)

Estas en el tema de script maldito (lentifica el reproductor) en el foro de Flash y Actionscript en Foros del Web. Unos amigos tienen una página ( http://www.gnmodels.com/ ) en la que un diseñador les estaba haciendo una aplicaciones en flash, resulta que este diseñador se ...
  #1 (permalink)  
Antiguo 13/12/2005, 07:14
Avatar de chaval  
Fecha de Ingreso: febrero-2003
Ubicación: en elgun lugar del cyberespacio
Mensajes: 118
Antigüedad: 14 años, 10 meses
Puntos: 0
script maldito (lentifica el reproductor)

Unos amigos tienen una página (http://www.gnmodels.com/) en la que un diseñador les estaba haciendo una aplicaciones en flash, resulta que este diseñador se fue de un día para el otro y dejo todo colgado y funcionando mal.

Cuando se corre la página (luego de ingresar) aparece la leyenda:

Cita:
Un script de esta pelicula esta provocando que el reproductor de flash se ejecute lentamente. Si continua ejecutandose, su Pc podria podria no responder. ¿desea anular el script?
Lo primero que se me ocurrio fueron 2 cosas:
- mala programación.
- diseñador enojado que compilo todo mal o decompilo y guardo con errores.

Se subio un backup (swf), supuestamente antiguo, al que este diseñador no tenia acceso y sigue el mismo problema.
La cosa es que llegaron a mi los .fla, los volvi a compilar sin ver en demasiado el codigo (por falta de tiempo y teniendo en cuenta que lo viejo tambien funcionaba mal) y continua funcionando mal.

¿A alguien se le ocurre algo?
¿puede ser algun tipo de configuracion del server o es lo que se me ocurrio a mi?¿puede existir algun problema con el flash palyer 8?

Ahora voy a probar todo localmente (no tengo flash aca) y en alguna máquina que no tenga el flash player 8 instalado.

gracias
El Chaval
__________________
CHAVAL
Buenos Aires, Argentina, América, La Tierra,
Via Lactea, Universo Tridemensional... :pensando:
  #2 (permalink)  
Antiguo 13/12/2005, 07:26
Avatar de lucasiramos  
Fecha de Ingreso: agosto-2004
Ubicación: Santa Rosa, La Pampa, Argentina
Mensajes: 1.484
Antigüedad: 13 años, 4 meses
Puntos: 13
Hola! El problema no es del reproductor ni mucho menos. Lo que ocurre es que tenes un bucle infinito. Revisá el código, paso por paso que tiene que haber un bucle infinito que te ande molestando, esto ocurre tanto localmente como desde Internet.

Saludos. Lucas
__________________
No sign...
  #3 (permalink)  
Antiguo 13/12/2005, 12:25
Avatar de chaval  
Fecha de Ingreso: febrero-2003
Ubicación: en elgun lugar del cyberespacio
Mensajes: 118
Antigüedad: 14 años, 10 meses
Puntos: 0
gracias Lucas, el problema era otro.
resulta que alguien cambio la clave en un php del que el flash leia las variables para conectarse a la BD por lo que quedaba tratando de conectarse en forma infinita.
__________________
CHAVAL
Buenos Aires, Argentina, América, La Tierra,
Via Lactea, Universo Tridemensional... :pensando:
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:57.