Foros del Web » Creando para Internet » Flash y Actionscript »

Sendandload, cambio de usuario y no funciona mas

Estas en el tema de Sendandload, cambio de usuario y no funciona mas en el foro de Flash y Actionscript en Foros del Web. uso la funcion sendandload en un flash, el problema es que cuando lo uso por primera vez, anda perfecto, pero cuando cambio de usuario en ...
  #1 (permalink)  
Antiguo 13/07/2009, 14:54
Avatar de chwc  
Fecha de Ingreso: julio-2008
Ubicación: Buenos Aires ! :D
Mensajes: 814
Antigüedad: 12 años, 4 meses
Puntos: 103
Sonrisa Sendandload, cambio de usuario y no funciona mas

uso la funcion sendandload en un flash, el problema es que cuando lo uso por primera vez, anda perfecto, pero cuando cambio de usuario en el navegador, ya el flash no hace el sendandload, a menos que cierre el navegador, vuelva a abrilo y elimine las cookies y la cache.

aqui esta el swf:http://halor.com.ar/ (entren con usuario a, contraseña a, y luego vayan a http://www.halor.com.ar/juegos/juego.php)

el codigo actionscript que uso es el siguiente:
Código actionscript:
Ver original
  1. _root.resultado.text = 'Espere...';
  2. var form_la:LoadVars = new LoadVars();
  3. form_la.coins = _root.coinss;
  4. form_la.juego = 'primero';
  5. form_la.user = _root.usuario;
  6. form_la.sendAndLoad("http://halor.com.ar/juegos/enviardatos.php",form_la,"POST");
  7. form_la.onLoad = function(){
  8. if(form_la["todook"] == "si"){
  9. _root.resultado.text = form_la.coins + form_la.juego + form_la.user;
  10. }else{
  11. _root.resultado.text = 'Error';
  12. }
  13. }
  14.  
  15. stop();

saludos
__________________
Hangouts de JavaScript todos los jueves 20hs GMT, Unite !
https://plus.google.com/u/0/108504944676960830886
  #2 (permalink)  
Antiguo 13/07/2009, 20:01
Avatar de chwc  
Fecha de Ingreso: julio-2008
Ubicación: Buenos Aires ! :D
Mensajes: 814
Antigüedad: 12 años, 4 meses
Puntos: 103
Sonrisa Respuesta: Sendandload, cambio de usuario y no funciona mas

ya solucione el problema

para aquellos que tengan este problema, les doy la solucion, despues de cuatro dias intentando resolverlo.

el problema es que el servidor tiene que tener un archivo crossdomain.xml en la base del servidor con el siguiente codigo:
Cita:
<?xml version="1.0"?><!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd"><cross-domain-policy> <allow-access-from domain="*" /></cross-domain-policy>
saludos a todos !
__________________
Hangouts de JavaScript todos los jueves 20hs GMT, Unite !
https://plus.google.com/u/0/108504944676960830886
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:39.