Foros del Web » Creando para Internet » Flash y Actionscript »

setMask en degrade con componentes

Estas en el tema de setMask en degrade con componentes en el foro de Flash y Actionscript en Foros del Web. Hola, intento hacer lo siguiente. En mi pelicula principal tengo un MC que dentro tiene un componente llamado IEloader, que es un reemplazo del clasico ...
  #1 (permalink)  
Antiguo 15/09/2008, 17:52
 
Fecha de Ingreso: noviembre-2006
Mensajes: 17
Antigüedad: 11 años
Puntos: 0
setMask en degrade con componentes

Hola, intento hacer lo siguiente.
En mi pelicula principal tengo un MC que dentro tiene un componente llamado IEloader, que es un reemplazo del clasico loader pero que funciona con todas las versiones de Internet Explorer. Bueno esto no viene al caso, lo que importa es que es un componente.
Por otro lado, tengo otro MC por encima del anterior, que contiene un grafico en degrade.
Lo que intento hacer es el clasico metodo para enmascarar un MC con degrade, pero resulta que por tener un componente dentro el metodo setMask no funciona bien. Depurando comprove que cacheAsBitmap funciona sin problema, la cuestion viene al querer hacer setMask con el cacheAsBitmap configurado en true, ya que si no los configuro, setMask funciona perfecto pero claro, sin el degrade qeu yo necesito.
Hay posibilidad de solucionar el problema?
  #2 (permalink)  
Antiguo 17/09/2008, 13:13
 
Fecha de Ingreso: noviembre-2006
Mensajes: 17
Antigüedad: 11 años
Puntos: 0
Respuesta: setMask en degrade con componentes

otra cosa nueva, probe publicar la pelicula (sin la mascara) por un lado, y hacer un loadmovie en un MC y enmascarar ese MC, pero tampoco me funciono, que puede ser¿?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:31.