Foros del Web » Creando para Internet » Flash y Actionscript »

un solo efecto

Estas en el tema de un solo efecto en el foro de Flash y Actionscript en Foros del Web. holas, miren lo q e intentado hacer pero no lo logro hacer xD, es algo asi: Tienes un mc con una pagina(titulo,contenido imagenes,etc) en el ...
  #1 (permalink)  
Antiguo 24/07/2006, 18:10
Avatar de DarkskullDA  
Fecha de Ingreso: julio-2006
Mensajes: 698
Antigüedad: 11 años, 5 meses
Puntos: 13
un solo efecto

holas,
miren lo q e intentado hacer pero no lo logro hacer xD, es algo asi:
Tienes un mc con una pagina(titulo,contenido imagenes,etc) en el primer frame, en otro otra pero con diferente info, y asi unas cuantas mas.

en tu pelicula principal pones el mc y le das un fecto ( aparicion y desaparece)
tines lso bootnecua cuando presiones el boton 1 te manda a el fecto de desaparicion tu mccon las pages y luego hace el efecto de aparicion con el mismo mcpages pero con la pagina 1.... si presionas el boton dos hace el efecto de desaparicion con la pag1 y luego con el mcpages aparece con el mismo efecto pero la pag 2

espero q me hayan entendido, tengo algunas ideas pero no me a quedado muy bien, si saben como o algun tuto o lo q sea :P, ayudenme plz ^^


grax :)
  #2 (permalink)  
Antiguo 24/07/2006, 19:00
Avatar de DarkskullDA  
Fecha de Ingreso: julio-2006
Mensajes: 698
Antigüedad: 11 años, 5 meses
Puntos: 13
alguien plzzz xD

tengo estos codigos pero no se bien como van por q no em esta funcionand o =(

Código:
onClipEvent (load)
{
    num = 2;
}
on (rollOver)
{
    if (_root.link != num)
    {
        this.gotoAndPlay("s1");
    } // end if
}
on (releaseOutside, rollOut)
{
    if (_root.link != num)
    {
        this.gotoAndPlay("s2");
    } // end if
}
on (release)
{
    if (_root.link != num && _root.animation == 1)
    {
        _root.animation = 0;
        _root.link_prev = _root.link;
        _parent["item" + _root.link].gotoAndPlay("s2");
        _root.link = num;
        _root.play();
    } // end if
}
eso para lso botones

y en la peli deve ir frames con el nombre o weno acciones de animation = 1
_root.link = 1

etc =((((

espero q alguien sepa de lo q hablo xD
PD:igual sigo intentando si lo hago funcionar subo el swf pa q vean (y tambien el fla)

saludos
  #3 (permalink)  
Antiguo 24/07/2006, 19:19
Avatar de DarkskullDA  
Fecha de Ingreso: julio-2006
Mensajes: 698
Antigüedad: 11 años, 5 meses
Puntos: 13
aqui ta en mi pag pa q vean a lo q me refiero

vean el funcionamiento ^^, es un solo efecto y funcioana con cada pag

http://dark666.iespana.es/skatesweb/skates.swf
tarda un minuto en cargar XD

Saludos ^^
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:37.