Foros del Web » Creando para Internet » Flash y Actionscript »

Solo funciona si hago doble click... AYUDA!

Estas en el tema de Solo funciona si hago doble click... AYUDA! en el foro de Flash y Actionscript en Foros del Web. Hola. Estoy haciendo una web en flash en la q utilizo carga de movies externas en una zona de carga en el archivo principal q ...
  #1 (permalink)  
Antiguo 10/03/2005, 04:55
 
Fecha de Ingreso: enero-2004
Mensajes: 149
Antigüedad: 13 años, 11 meses
Puntos: 1
Solo funciona si hago doble click... AYUDA!

Hola. Estoy haciendo una web en flash en la q utilizo carga de movies externas en una zona de carga en el archivo principal q tiene como instancia "carga".

En uno de los apartados hay una serie de menus q se despliegan y una vez desplegados tienen una zona activa de un boton para volver a su posicion inicial. Todos estos menus son clips de pelicula y tienen sobre ellos un boton transparente con la orden de play (la animacion dentro del clip q hace q se desplegue). También tiene asignado un telltarget que manda a cada menu a un fotograma en la escena de este archivo en donde solo se mantiene como movie el menu activo, y los otros no hacen nada. La orden q le tengo puesta es la siguiente:

on (release) {
play();
tellTarget ("_root.carga.home") {
gotoAndStop("local");
}
}

esta es la programacion del menu "local".

El caso es que antes lo tenia con un rollover y funcionaba bien (pero era algo confuso) www.imagital.com/localia --> esta es la web, y el problema en cuestion es en el inicio. Sin embargo, al ponerle on release sigue funcionando, pero tengo que hacer doble click

Lo he mirado todo a ver si hubiera algun clip duplicado o algo, pero nada... alguien sabe por que pasa esto?
  #2 (permalink)  
Antiguo 10/03/2005, 05:11
 
Fecha de Ingreso: enero-2004
Mensajes: 149
Antigüedad: 13 años, 11 meses
Puntos: 1
pues ya esta

el fallo era tan simple como q no habia continuidad en el time line del clip q se tiene q reproducir, asi q un click te mandaba al fotograma con label y otro lo reproducia. Al final ha sido tan facil como ponerle la orden play en estos fotogramas con label mediante un tell target
  #3 (permalink)  
Antiguo 06/05/2005, 00:13
Avatar de goc00  
Fecha de Ingreso: enero-2002
Ubicación: 000's DiMensiOn
Mensajes: 979
Antigüedad: 15 años, 10 meses
Puntos: 3
¿Puedes explicar un poco mejor la respuesta?, ya que creo tener el mismo problema (ojalá siga vivo este usuario -strepor- )
__________________
GOC00 CominG soOn v2.0
CyA! & GooD LuCK...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:22.