Foros del Web » Creando para Internet » Flash y Actionscript »

Solo para super expertos

Estas en el tema de Solo para super expertos en el foro de Flash y Actionscript en Foros del Web. Aqui les caigo despues de muuucho tiempo, pero con la esperanza de que me ayuden brothers genios del flash.... aqui les va: Acabo de hacer ...
  #1 (permalink)  
Antiguo 04/11/2004, 16:05
Avatar de papuchango  
Fecha de Ingreso: febrero-2003
Mensajes: 304
Antigüedad: 14 años, 9 meses
Puntos: 0
Exclamación Solo para super expertos

Aqui les caigo despues de muuucho tiempo, pero con la esperanza de que me ayuden brothers genios del flash....

aqui les va:

Acabo de hacer un movie con un componente, el media play back para ser exacto, todo belleza, pero llego la hora del loader. Llevo haciendo flash desde hace 4 años y por primera vez no me funciona... o mas bien me funciona a medias, pues en la simulacion de carga el loader aparece despues de que lleva el 70 porciento de la carga!!!. Bueno, me puse a buscar y buscar y note derrepente que el primer fotograma de mi pelicula, el fotograma del loader pesa absurdamente 85 kb!!! algo inaceptable para un simbolito que consta de solo rellenos y bordes vectoriales!!!... en mi afan de ver si habia algun objeto intruso en mi loader pido a mi pelicula me genere un informe de tamaño, generandome para el frame numero uno lo siguiente:

------------------------------------
Fotograma # Fotograma Bytes Total Bytes Escena
----------- --------------- ----------- -----------------
1 79052 79052 Escena 1 (Fotograma de exportación para clases de AS 2.0)
2 0 79052
3 0 79052
4 0 79052
5 5671 84723
6 0 84723
7 0 84723
8 0 84723
9 0 84723


por lo que entiendo, el inche componente malnacido, genera codigo as , clases para ser exacto, y me los coloca en el frame 1 haciendo inutil a mi cargador!!!!

bueno... encontre una opcion que me permite cambiar el fotograma de exportacion de clases as 2.0... el problema es que al cambiarlo el componente se fastidia y deja de funcionar.... existe otra opcion para seleccionar el archivo as para la importacion de esta clase sin ponerlo en el frame uno... el problema es que no se que codigo poner al archivo as para generar la clase necesaria....

bueno... tremendo lio en el que me meti verda?.... pero el foro esta rodeado de genios...asi que confio que me ayudaran sin dudarlo....

gracias a todos... se que podran con esta!

saludos!
  #2 (permalink)  
Antiguo 04/11/2004, 16:51
cmc
 
Fecha de Ingreso: febrero-2003
Ubicación: Capital
Mensajes: 1.317
Antigüedad: 14 años, 10 meses
Puntos: 1
Mira no estoy muy seguro que sea el mismo caso que me paso a mi yo me canse de los componentes que flash te lo carga en el primer frame por mas que yo lo utiliza en el ultimo frame de mi película por lo cual me mande a hacer un a precarga de mi película pero desde fuera de ella para lo cual me nutrí de un componente que desarrollo maltos y lo modifique a mi necesidad, por los conocimientos que decís que tenes no tendrías que tener inconveniente en hacerlo.
Te aconsejo que lo pruebes

Suerte
__________________
Claudio Caldareri
diseñador Multimedial
www.disemedios.com.ar
  #3 (permalink)  
Antiguo 04/11/2004, 17:07
Avatar de papuchango  
Fecha de Ingreso: febrero-2003
Mensajes: 304
Antigüedad: 14 años, 9 meses
Puntos: 0
estaba pensando en ello... pero despues de un dia laburando en un proyecto y que te aparezca un absurdo como este...te quita la inspiracion men... en fin... inches componentes...

gracias por tu pronta respuesta... saludos!

Última edición por papuchango; 04/11/2004 a las 17:09
  #4 (permalink)  
Antiguo 04/11/2004, 17:42
Avatar de TMeister
Crazy Coder
 
Fecha de Ingreso: enero-2002
Ubicación: En la Oficina
Mensajes: 2.880
Antigüedad: 15 años, 11 meses
Puntos: 193
Aqui se habla del asunto.....

hay un ejemplo y todo.. http://flashla.com/forums/viewtopic.php?t=7808&start=15
  #5 (permalink)  
Antiguo 05/11/2004, 06:55
Avatar de papuchango  
Fecha de Ingreso: febrero-2003
Mensajes: 304
Antigüedad: 14 años, 9 meses
Puntos: 0
uta...con polemica y todo...





gracias bro...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:09.