Foros del Web » Creando para Internet » Flash y Actionscript »

Sonido en flash

Estas en el tema de Sonido en flash en el foro de Flash y Actionscript en Foros del Web. necesito saber dos cosas de flash mx 1ra como hacer para que un sonido insertado en el primer k-frame de la 1 escena suene en ...
  #1 (permalink)  
Antiguo 17/02/2005, 13:38
 
Fecha de Ingreso: febrero-2005
Mensajes: 1
Antigüedad: 12 años, 9 meses
Puntos: 0
Exclamación Sonido en flash


necesito saber dos cosas de flash mx
1ra como hacer para que un sonido insertado en el primer k-frame de la 1 escena suene en toda la presentacion...osea que no deje de sonar cuando uno cambie de escenas o unda botones etc...

y segunada como hago para que la presentacion no se salte imagenes....
  #2 (permalink)  
Antiguo 17/02/2005, 13:49
Avatar de junihh  
Fecha de Ingreso: febrero-2004
Ubicación: República Dominicana
Mensajes: 997
Antigüedad: 13 años, 10 meses
Puntos: 7
Ni uno ni otro.

Primero, cuando insertas un sonido en la primera escena, este seguira sonando en todo momento, independientemente de la cantidad de escenas que tenga tu animacion o los botones que aprietes, a menos que esos botones tengan el script stopAllSounds().

Segundo, la presentacion no saltara imagenes si no le dices que lo haga. Por ejemplo, supongamos que tienes una foto en el frame 6, a menos que en el frame 5 pongas algo como: gotoAndPlay(7), la animacion pasara por el 4 > 5 > 6 > 7 > 8 sin saltarse el 6 y asi mostrar tu foto.

No se si te respondi, de lo contrario creo debes explicar mejor lo que quieres.
__________________
JuniHH
- Mi blog
- Mi portafolio
  #3 (permalink)  
Antiguo 18/02/2005, 01:14
Avatar de miguelmartinez  
Fecha de Ingreso: febrero-2005
Mensajes: 42
Antigüedad: 12 años, 9 meses
Puntos: 0
UN PROBLEMA SIMILAR....quiero poder controlar si un sonido de fondo se escucha o no....he logrado detenerlo con StopAllSounds() pero no he logrado que vuelva a escucharse, puse un boton en escena 1 y que se abrinca a escena 2 al presionarlo, pero antes de saltar usa stopallsound.....al llegar a la segunda escena aparace el boton para inicar nuevamente el sonido..esto lo intento...usando gotoandplay(escena1, frame) con el fin de que vuelva al inicio de todo...pero no funciona
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:39.