Foros del Web » Creando para Internet » Flash y Actionscript »

Sonido y Video

Estas en el tema de Sonido y Video en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un problema de sincronización de video y de sonido en en escena principal ( es para un CD-Rom) en mi escena princiapl tengo ...
  #1 (permalink)  
Antiguo 13/03/2006, 04:23
 
Fecha de Ingreso: marzo-2006
Mensajes: 1
Antigüedad: 11 años, 9 meses
Puntos: 0
Sonido y Video

Hola, tengo un problema de sincronización de video y de sonido en en escena principal ( es para un CD-Rom)
en mi escena princiapl tengo un sonido en bucle
(musica = new Sound();
musica.attachSound("guitarra");
musica.setVolume(100);)

llega un momento del cd-rom que cuando pincha en un boton se carga el video en load movie donde en la 1ªframe está el código siguiente:
var netConn:NetConnection = new NetConnection();
netConn.connect(null);
var netStream:NetStream = new NetStream(netConn);
maVideo.attachVideo(netStream);
netStream.setBufferTime(2);
netStream.play("begijar.flv");

El problema que tengo es que cuando pinche en el boiton para cargar el video, que el sonido del ficchero principal tenga un setVolume(0) para oir el video.un setVolume del video de (100). pero no soy capaz de conseguirlo : o se corta los 2 sonidos o se oyen los dos mezclados.
Alguien tendraá una solución o un recurso porfavor?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:01.